aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2007-01-14 15:27:47 +0800
committerkuriyama <kuriyama@FreeBSD.org>2007-01-14 15:27:47 +0800
commitd4791e14569f2442f797a9ad51397ab494d41759 (patch)
treed50e99498d6dd5f43b66a6c058e30a84e00d226b /security
parent7b0d2fcf99cc910e504711e933dbb3e918a7a6f9 (diff)
downloadfreebsd-ports-graphics-d4791e14569f2442f797a9ad51397ab494d41759.tar.gz
freebsd-ports-graphics-d4791e14569f2442f797a9ad51397ab494d41759.tar.zst
freebsd-ports-graphics-d4791e14569f2442f797a9ad51397ab494d41759.zip
Fix breakage.
Diffstat (limited to 'security')
-rw-r--r--security/gnupg/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index febb9ad395d..0e3bb000ac9 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -41,10 +41,10 @@ MAN8= addgnupghome.8
INFO= gnupg
OPTIONS= LDAP "LDAP keyserver interface" off \
+ NLS "National Language Support" off \
SCDAEMON "Enable Smartcard daemon (with libusb)" off \
CURL "Use the real curl library (worked around if no)" on \
GPGSM "Enable GPGSM" on
-PLIST_SUB= NLS=""
.include <bsd.port.pre.mk>
@@ -66,6 +66,14 @@ CONFIGURE_ARGS+=--disable-ldap
PLIST_SUB+= LDAP="@comment "
.endif
+.if defined(WITH_NLS)
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if defined(WITH_SCDAEMON)
CONFIGURE_ARGS+=--enable-scdaemon
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb