aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-05-11 21:27:55 +0800
committergarga <garga@FreeBSD.org>2006-05-11 21:27:55 +0800
commitd7734ce146c82099682fd388627c512d0d3e826f (patch)
tree13befa305cdb3fe9db5bc49390305fa6cdf689ce /security
parent45328855b3fbf7068aa9dd412f03fbdee5eeb83e (diff)
downloadfreebsd-ports-graphics-d7734ce146c82099682fd388627c512d0d3e826f.tar.gz
freebsd-ports-graphics-d7734ce146c82099682fd388627c512d0d3e826f.tar.zst
freebsd-ports-graphics-d7734ce146c82099682fd388627c512d0d3e826f.zip
Patch include.inc.php to fix a javascript error caused by a missing form name
Submitted by: Davide D'Amico <d.damico__informeditalia.net> on pfw maillist
Diffstat (limited to 'security')
-rw-r--r--security/pfw/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/pfw/Makefile b/security/pfw/Makefile
index 465d1e5f352..9e885f9679d 100644
--- a/security/pfw/Makefile
+++ b/security/pfw/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pfw
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= security www
MASTER_SITES= http://www.allard.nu/pfw/download/
EXTRACT_SUFX= .tgz
@@ -18,7 +19,7 @@ RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PHP= session pcre sqlite
+USE_PHP= session pcre # sqlite
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
BROKEN_WITH_PHP=4
@@ -38,6 +39,10 @@ PORTDOCS= INSTALL README README_TEST
IGNORE= pf is only in 5.x and newer
.endif
+post-patch:
+ @${REINPLACE_CMD} -E 's,id=("theform"),name=\1 id=\1,' \
+ ${WRKSRC}/include.inc.php
+
do-install:
${MKDIR} ${PFW_PREFIX}
${INSTALL_DATA} ${WRKSRC}/include.inc.php ${PFW_PREFIX}