aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-11-05 00:42:44 +0800
committervanilla <vanilla@FreeBSD.org>2003-11-05 00:42:44 +0800
commitde5569ca62bc30b90ad18423f76538185d14b367 (patch)
tree612407b76a963a95e0845497ba2f5741111172dc /security
parent9e39bff128683212e565f18fea263e4dd9ec258d (diff)
downloadfreebsd-ports-graphics-de5569ca62bc30b90ad18423f76538185d14b367.tar.gz
freebsd-ports-graphics-de5569ca62bc30b90ad18423f76538185d14b367.tar.zst
freebsd-ports-graphics-de5569ca62bc30b90ad18423f76538185d14b367.zip
Add p5-Crypt-OFB 0.01, encrypt Data using OFB Mode.
PR: 58825 Submitted by: clsung
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OFB/Makefile25
-rw-r--r--security/p5-Crypt-OFB/distinfo1
-rw-r--r--security/p5-Crypt-OFB/pkg-descr6
-rw-r--r--security/p5-Crypt-OFB/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a6421f0e897..d252072bbe6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -227,6 +227,7 @@
SUBDIR += p5-Crypt-GeneratePassword
SUBDIR += p5-Crypt-HCE_SHA
SUBDIR += p5-Crypt-IDEA
+ SUBDIR += p5-Crypt-OFB
SUBDIR += p5-Crypt-OTP
SUBDIR += p5-Crypt-OpenPGP
SUBDIR += p5-Crypt-OpenSSL-Bignum
diff --git a/security/p5-Crypt-OFB/Makefile b/security/p5-Crypt-OFB/Makefile
new file mode 100644
index 00000000000..af3768037ca
--- /dev/null
+++ b/security/p5-Crypt-OFB/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-OFB
+# Date created: Nov 2 2003
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OFB
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Encrypt Data using OFB Mode
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/ECB.pm:${PORTSDIR}/security/p5-Crypt-ECB
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OFB.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OFB/distinfo b/security/p5-Crypt-OFB/distinfo
new file mode 100644
index 00000000000..ef6f15b6a1e
--- /dev/null
+++ b/security/p5-Crypt-OFB/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OFB-0.01.tar.gz) = 4d23f4d5c773cddf85e347ba36a6df6b
diff --git a/security/p5-Crypt-OFB/pkg-descr b/security/p5-Crypt-OFB/pkg-descr
new file mode 100644
index 00000000000..9c23be9b0cd
--- /dev/null
+++ b/security/p5-Crypt-OFB/pkg-descr
@@ -0,0 +1,6 @@
+This module is a Perl-only implementation of the OFB mode.
+Where OFB stands for Output Feedback Block.
+
+WWW: http://search.cpan.org/search?dist=Crypt-OFB
+
+Autho: GUGOD <gugod@guguod.org>
diff --git a/security/p5-Crypt-OFB/pkg-plist b/security/p5-Crypt-OFB/pkg-plist
new file mode 100644
index 00000000000..6b4f7791807
--- /dev/null
+++ b/security/p5-Crypt-OFB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/OFB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OFB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OFB
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true