aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-11-07 05:19:33 +0800
committerhrs <hrs@FreeBSD.org>2016-11-07 05:19:33 +0800
commite88d947af5e364c59990fa0bf3aa5b2fcec6baa7 (patch)
tree2a94ba1f62e014461c3c5a4ceaada2db9d313594 /security
parent22dd72e79033396d153da3e38a0d67695d301be3 (diff)
downloadfreebsd-ports-graphics-e88d947af5e364c59990fa0bf3aa5b2fcec6baa7.tar.gz
freebsd-ports-graphics-e88d947af5e364c59990fa0bf3aa5b2fcec6baa7.tar.zst
freebsd-ports-graphics-e88d947af5e364c59990fa0bf3aa5b2fcec6baa7.zip
Add obsolete window size hint information. This solved
a problem with i3 window manager which could make the ssh-askpass window too small. Suggested by: Guilherme Salazar Obtained from: https://groups.google.com/forum/#!topic/mailing.openbsd.tech/MKSja1XZzOs
Diffstat (limited to 'security')
-rw-r--r--security/openssh-askpass/Makefile2
-rw-r--r--security/openssh-askpass/files/patch-x11-ssh-askpass.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/security/openssh-askpass/Makefile b/security/openssh-askpass/Makefile
index 3b90fb190de..dafdc6cc55d 100644
--- a/security/openssh-askpass/Makefile
+++ b/security/openssh-askpass/Makefile
@@ -3,7 +3,7 @@
PORTNAME= OpenSSH-askpass
PORTVERSION= 1.2.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://www.jmknoble.net/software/x11-ssh-askpass/
DISTNAME= x11-ssh-askpass-${PORTVERSION}
diff --git a/security/openssh-askpass/files/patch-x11-ssh-askpass.c b/security/openssh-askpass/files/patch-x11-ssh-askpass.c
new file mode 100644
index 00000000000..ba3b499cee1
--- /dev/null
+++ b/security/openssh-askpass/files/patch-x11-ssh-askpass.c
@@ -0,0 +1,13 @@
+--- x11-ssh-askpass.c.orig 2016-11-06 16:18:21.595954000 +0900
++++ x11-ssh-askpass.c 2016-11-06 16:20:39.207609000 +0900
+@@ -764,6 +764,10 @@
+ d->sizeHints->flags = 0;
+ d->sizeHints->flags |= PPosition;
+ d->sizeHints->flags |= PSize;
++ d->sizeHints->x = d->w3.w.x;
++ d->sizeHints->y = d->w3.w.y;
++ d->sizeHints->width = d->w3.w.width;
++ d->sizeHints->height = d->w3.w.height;
+ d->sizeHints->min_width = d->w3.w.width;
+ d->sizeHints->min_height = d->w3.w.height;
+ d->sizeHints->flags |= PMinSize;