aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2006-01-26 03:17:14 +0800
committermi <mi@FreeBSD.org>2006-01-26 03:17:14 +0800
commitf37b9907d0cad6621520c6b932989df59d50bc83 (patch)
treeb4b1240433c79acdd3e4d1d4166e540ec4202d37 /security
parenta1fe7dede1c1f856a4ffcfc0e1d44e4f054e120e (diff)
downloadfreebsd-ports-graphics-f37b9907d0cad6621520c6b932989df59d50bc83.tar.gz
freebsd-ports-graphics-f37b9907d0cad6621520c6b932989df59d50bc83.tar.zst
freebsd-ports-graphics-f37b9907d0cad6621520c6b932989df59d50bc83.zip
Update from 1.2.4 to 1.2.9. Switch to using OPTIONS and add nss as
one of the optional back-ends. Approved by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/xmlsec1/Makefile69
-rw-r--r--security/xmlsec1/distinfo6
2 files changed, 48 insertions, 27 deletions
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index e3b39bc3450..bd40ffea6a3 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmlsec1
-PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTVERSION= 1.2.9
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \
@@ -20,38 +19,28 @@ COMMENT= XML Security Library
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
BUILD_DEPENDS= ${RUN_DEPENDS}
+OPTIONS= GNUTLS "Enable GNUTLS support" off \
+ NSS "Enable Mozilla's NSS support" off
+
USE_OPENSSL= yes
+OPENSSL_CFLAGS+=-DXMLSEC_OPENSSL_097=1 -DXMLSEC_CRYPTO_OPENSSL=1
USE_GNOME= gnomehack lthack libxslt gnometarget
USE_REINPLACE= yes
-USE_AUTOTOOLS= libtool:13
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
PLIST_FILES= bin/xmlsec1 bin/xmlsec1-config etc/xmlsec1Conf.sh
MAN1= xmlsec1.1 xmlsec1-config.1
-
-.if defined(WITH_GNUTLS)
-CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
-LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
+# The software comes with its own tests, but it is nauseating to sort,
+# which failures are, and which aren't legitimate. Some other day, maybe.
+#ALL_TARGET= all check-all
+MAKE_ENV+= ABS_BUILDDIR=${WRKSRC} TMPFOLDER=${WRKSRC}
+MAKE_ARGS+= -EABS_BUILDDIR
.if !defined(NOPORTDOCS)
-MAKE_ENV= DOCS=docs
+MAKE_ENV+= DOCS=docs
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_GNUTLS=yes Enable GNUTLS support"
- @${ECHO} ""
-
-post-patch:
- @${REINPLACE_CMD} -e 's|src apps man docs|src apps man \$${DOCS}|g ; \
- s|^confexecdir =.*$$|confexecdir = \$$(sysconfdir)|g' \
- ${WRKSRC}/Makefile.in
-
post-install:
@${FIND} ${PREFIX}/include/xmlsec1 -type f | \
${SED} 's,${PREFIX}/,,' >> ${TMPPLIST}
@@ -65,4 +54,36 @@ post-install:
@${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
${SED} 's,${PREFIX}/,, ; s,^,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GNUTLS)
+CONFIGURE_ARGS+= --with-gnutls="${LOCALBASE}"
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= --without-gnutls
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|src apps man docs|src apps man \$${DOCS}|g' \
+ -e 's|^confexecdir =.*$$|confexecdir = \$$(sysconfdir)|g' \
+ -e 's|/tmp/\*\.log|${WRKSRC}/*.log|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-ldl"|"|' \
+ -e 's,with_nspr/include,with_nspr/include/nspr ${PTHREAD_CFLAGS},' \
+ -e 's,with_nss/include,with_nss/include/nss/nss,' \
+ -e 's,\(CPPFLAGS="\$$NSS_CFLAGS\),\1 $$NSPR_CFLAGS,' \
+ -e 's,\(-lplc4\)",\1 ${PTHREAD_LIBS}",' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+.if defined(WITH_NSS)
+ # Makeing the xmlsec1 executable multi-threaded to let load -lnss,
+ # when needed.
+ @${REINPLACE_CMD} -e 's,^\(xmlsec1_LDADD = \)\\$$,\1 ${PTHREAD_LIBS}\\,' \
+ ${WRKSRC}/apps/Makefile.in
+
+CONFIGURE_ARGS+= --with-nss="${LOCALBASE}" --with-nspr="${LOCALBASE}"
+LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+.else
+CONFIGURE_ARGS+= --without-nss
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/xmlsec1/distinfo b/security/xmlsec1/distinfo
index 4d9a6208803..3584bf12aa0 100644
--- a/security/xmlsec1/distinfo
+++ b/security/xmlsec1/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmlsec1-1.2.4.tar.gz) = 1d6ef139d74434da78051de610e7a4f3
-SHA256 (xmlsec1-1.2.4.tar.gz) = cd1eb358c900b63b28f3f520bd05638745b6880d3788186ab23a6ae829b5ba1d
-SIZE (xmlsec1-1.2.4.tar.gz) = 1431760
+MD5 (xmlsec1-1.2.9.tar.gz) = b378a076708766966724aaeba09e4607
+SHA256 (xmlsec1-1.2.9.tar.gz) = 2ab5834d0d0488df9862ae9ccc6920a826584e2740dd0be1c8cc9d4f17249814
+SIZE (xmlsec1-1.2.9.tar.gz) = 1667363