aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash2
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1997-06-28 07:03:34 +0800
committerache <ache@FreeBSD.org>1997-06-28 07:03:34 +0800
commit6b1aa5e6710480114e95fc4136141f9374d1f57e (patch)
tree22b248d10764f83e8d13a4a9c3777b49e7009329 /shells/bash2
parent3a325c3f6fb68f043d6e622110daa5e2e241c266 (diff)
downloadfreebsd-ports-graphics-6b1aa5e6710480114e95fc4136141f9374d1f57e.tar.gz
freebsd-ports-graphics-6b1aa5e6710480114e95fc4136141f9374d1f57e.tar.zst
freebsd-ports-graphics-6b1aa5e6710480114e95fc4136141f9374d1f57e.zip
Install /etc/shells entry and info dir entry
PR: 3971
Diffstat (limited to 'shells/bash2')
-rw-r--r--shells/bash2/Makefile10
-rw-r--r--shells/bash2/files/patch-aa21
2 files changed, 30 insertions, 1 deletions
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 38e234998f2..fab0686fb50 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.24 1997/05/26 22:21:51 ache Exp $
+# $Id: Makefile,v 1.25 1997/06/06 23:13:49 ache Exp $
#
DISTNAME= bash-2.01
@@ -22,7 +22,15 @@ MAN1= bash.1 bashbug.1
post-patch:
cp /usr/include/fnmatch.h ${WRKSRC}/lib/glob/fnmatch.h
+pre-install:
+ if [ ! -s ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+
post-install:
+ ${CP} /etc/shells /etc/shells.bak
+ (${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; echo ${PREFIX}/bin/bash) >/etc/shells
+ ${RM} /etc/shells.bak
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/bash
${INSTALL_MAN} \
diff --git a/shells/bash2/files/patch-aa b/shells/bash2/files/patch-aa
new file mode 100644
index 00000000000..16d0302deba
--- /dev/null
+++ b/shells/bash2/files/patch-aa
@@ -0,0 +1,21 @@
+*** doc/Makefile.in.bak Fri Jan 31 00:12:33 1997
+--- doc/Makefile.in Sat Jun 28 02:23:01 1997
+***************
+*** 155,161 ****
+ -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
+ # run install-info if it is present to update the info directory
+ if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
+! install-info --dir-file=$(infodir)/dir $(infodir)/bash.info; \
+ else true; fi
+
+ uninstall:
+--- 155,163 ----
+ -$(INSTALL_DATA) $(srcdir)/bashref.info $(infodir)/bash.info
+ # run install-info if it is present to update the info directory
+ if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
+! install-info \
+! --defentry="* BASH: (bash). Bash Reference Manual." \
+! --dir-file=$(infodir)/dir $(infodir)/bash.info; \
+ else true; fi
+
+ uninstall: