aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2010-09-07 04:30:14 +0800
committeradamw <adamw@FreeBSD.org>2010-09-07 04:30:14 +0800
commit2bb4d7f0c1e7b036c2c3540ac71f0cdf13268bfd (patch)
treee86efbc849c199972aaf95b385ea49e2ab24d6d1 /shells
parent6c2b18cee7913d8cf9f1ced4e62361a4a4890d32 (diff)
downloadfreebsd-ports-graphics-2bb4d7f0c1e7b036c2c3540ac71f0cdf13268bfd.tar.gz
freebsd-ports-graphics-2bb4d7f0c1e7b036c2c3540ac71f0cdf13268bfd.tar.zst
freebsd-ports-graphics-2bb4d7f0c1e7b036c2c3540ac71f0cdf13268bfd.zip
The rsync completion plugin causes the shell to freeze on amd64.
Until that gets resolved, I'm disconnecting the rsync plugin from the build on amd64. PR: ports/150322 Submitted by: ehaupt
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-completion-classic/Makefile15
-rw-r--r--shells/bash-completion-classic/pkg-plist2
-rw-r--r--shells/bash-completion/Makefile15
-rw-r--r--shells/bash-completion/pkg-plist2
4 files changed, 28 insertions, 6 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 6fffcfb6690..ad0cec8ca4d 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -21,6 +22,15 @@ RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+AMD64_REMOVE_RSYNC= /contrib\/rsync/d
+PLIST_SUB+= NOAMD64="@comment "
+.else
+PLIST_SUB+= NOAMD64=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -31,10 +41,11 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|' \
+ s|\(FLAC\)|\1\|flv\|FLV|; \
+ ${AMD64_REMOVE_RSYNC}' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/bash-completion-classic/pkg-plist b/shells/bash-completion-classic/pkg-plist
index 5fc2329a075..da9385be945 100644
--- a/shells/bash-completion-classic/pkg-plist
+++ b/shells/bash-completion-classic/pkg-plist
@@ -124,7 +124,7 @@ etc/bash_completion.d/rpcdebug
etc/bash_completion.d/rpm
etc/bash_completion.d/rpmcheck
etc/bash_completion.d/rrdtool
-etc/bash_completion.d/rsync
+%%NOAMD64%%etc/bash_completion.d/rsync
etc/bash_completion.d/rtcwake
etc/bash_completion.d/samba
etc/bash_completion.d/sbcl
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 6fffcfb6690..ad0cec8ca4d 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
@@ -21,6 +22,15 @@ RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+AMD64_REMOVE_RSYNC= /contrib\/rsync/d
+PLIST_SUB+= NOAMD64="@comment "
+.else
+PLIST_SUB+= NOAMD64=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -31,10 +41,11 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|' \
+ s|\(FLAC\)|\1\|flv\|FLV|; \
+ ${AMD64_REMOVE_RSYNC}' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in ${WRKSRC}/contrib/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 5fc2329a075..da9385be945 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -124,7 +124,7 @@ etc/bash_completion.d/rpcdebug
etc/bash_completion.d/rpm
etc/bash_completion.d/rpmcheck
etc/bash_completion.d/rrdtool
-etc/bash_completion.d/rsync
+%%NOAMD64%%etc/bash_completion.d/rsync
etc/bash_completion.d/rtcwake
etc/bash_completion.d/samba
etc/bash_completion.d/sbcl