aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-09-02 01:21:27 +0800
committerthierry <thierry@FreeBSD.org>2005-09-02 01:21:27 +0800
commit8972dd4348681671b208345fd5f9ddf858a5c525 (patch)
tree5ed08603dbb4a2436ef0cad6f1676e54edf3b083 /shells
parent0348ebdc3dede0753d94f9786b7300e73916d57c (diff)
downloadfreebsd-ports-graphics-8972dd4348681671b208345fd5f9ddf858a5c525.tar.gz
freebsd-ports-graphics-8972dd4348681671b208345fd5f9ddf858a5c525.tar.zst
freebsd-ports-graphics-8972dd4348681671b208345fd5f9ddf858a5c525.zip
- Re-add patch-configure (removed by mistake) to fix the build on the cluster;
- handle ADACFLAGS. Note: update to 1.0.3 is in progress.
Diffstat (limited to 'shells')
-rw-r--r--shells/bush/Makefile2
-rw-r--r--shells/bush/files/patch-configure14
-rw-r--r--shells/bush/files/patch-src_GNUmakefile.diff14
3 files changed, 28 insertions, 2 deletions
diff --git a/shells/bush/Makefile b/shells/bush/Makefile
index 1f600e3743b..4a922df164e 100644
--- a/shells/bush/Makefile
+++ b/shells/bush/Makefile
@@ -22,9 +22,11 @@ BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat \
USE_PGSQL= yes
HAS_CONFIGURE= yes
+ADACFLAGS?= ${CFLAGS:N-fno-strict-aliasing}
USE_GMAKE= yes
MAKE_ARGS= GMAKE=${GMAKE} CPUTYPE=${CPUTYPE} PTHREAD_LIBS=${PTHREAD_LIBS} \
SDL_CONFIG=${SDL_CONFIG}
+MAKE_ENV= ADACFLAGS="${ADACFLAGS}"
MAKEFILE= GNUmakefile
USE_SDL= sdl image
USE_MYSQL= yes
diff --git a/shells/bush/files/patch-configure b/shells/bush/files/patch-configure
new file mode 100644
index 00000000000..6456cabfe6d
--- /dev/null
+++ b/shells/bush/files/patch-configure
@@ -0,0 +1,14 @@
+--- configure.orig Tue Aug 16 01:45:37 2005
++++ configure Wed Aug 31 22:12:06 2005
+@@ -321,9 +321,8 @@
+ else
+ echo "no"
+ echo
+- echo "ADAVOX requires /dev/dsp. Create a /dev/dsp symlink to your real audio device"
+- echo "(If you don't care about audio support, try ln -s /dev/null /dev/dsp)"
+- exit 1
++ echo "ADAVOX requires /dev/dsp."
++ echo "Note that you should enable /dev/dsp on the machine on which you will install this package."
+ fi
+
+ echo "ADAVOX library is configured"
diff --git a/shells/bush/files/patch-src_GNUmakefile.diff b/shells/bush/files/patch-src_GNUmakefile.diff
index 39cc047c09d..e4bff89d135 100644
--- a/shells/bush/files/patch-src_GNUmakefile.diff
+++ b/shells/bush/files/patch-src_GNUmakefile.diff
@@ -1,11 +1,21 @@
--- src/GNUmakefile.orig.orig Wed Aug 17 22:59:07 2005
-+++ src/GNUmakefile.orig Wed Aug 24 23:45:36 2005
-@@ -11,7 +11,7 @@
++++ src/GNUmakefile.orig Wed Aug 31 22:35:03 2005
+@@ -11,7 +11,8 @@
GNATMAKE=gnatmake
SDLLIBS=SDLLIBSTYPE
SDLINCL=SDLINCLTYPE
-CFLAGS=CFLAGSTYPE
+CFLAGS+=CFLAGSTYPE
++ADACFLAGS+=CFLAGSTYPE
# For SDL, sdl_config is not always available.
# RPM Directories For Building an RPM file
+@@ -75,7 +76,7 @@
+ @echo
+
+ c_os.o: c_os.c
+- $(CC) $(CFLAGS) $(INCLUDE) -Wall -c c_os.c
++ $(CC) $(ADACFLAGS) $(INCLUDE) -Wall -c c_os.c
+
+ #apq-2.1/Makeincl:
+ # @echo "---------------------------------------------------------------"