aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2007-03-22 01:36:19 +0800
committersergei <sergei@FreeBSD.org>2007-03-22 01:36:19 +0800
commitbba5f7acd72c7d9f4f49ba025d1c8fa9ae99e455 (patch)
tree3c0c4954dce043351d72ab7a4fb6114beef6dd08 /shells
parent88ce5d63b8497af9faa4659d1925efa53c254873 (diff)
downloadfreebsd-ports-graphics-bba5f7acd72c7d9f4f49ba025d1c8fa9ae99e455.tar.gz
freebsd-ports-graphics-bba5f7acd72c7d9f4f49ba025d1c8fa9ae99e455.tar.zst
freebsd-ports-graphics-bba5f7acd72c7d9f4f49ba025d1c8fa9ae99e455.zip
- Use proper NO_SHARED knob instead of obsoleted NOSHARED
PR: ports/108327 Submitted by: Josh Carroll (floyd AT pflog DOT net)
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 3aa53fd771f..3b8fcfcda27 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -6,7 +6,7 @@
#
# The following compile-time options are available:
-# NOSHARED=yes compile a static version of zsh
+# NO_SHARED=yes compile a static version of zsh
# (default: use dynamically loadable modules)
# WITHOUT_ZSH_MEM=yes disable zsh-mem and zsh-secure-free options
# (default: on)
@@ -75,7 +75,7 @@ CONFIGURE_ARGS+= --enable-zsh-mem --enable-zsh-secure-free
CONFIGURE_ARGS+= --enable-maildir-support
.endif
-.if defined(NOSHARED)
+.if defined(NO_SHARED)
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -static"
CONFIGURE_ARGS+= --disable-dynamic
PLIST_SUB+= NO_STATIC="@comment "