aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2010-01-22 22:29:35 +0800
committerdes <des@FreeBSD.org>2010-01-22 22:29:35 +0800
commitcf5ce99a0b2df38416139487a238cc60fe016cca (patch)
treee08f0ebf7d4bb2123c0a33aa56badbc051f8f0a4 /shells
parenta043ca56f4f2eee106523cc0a12bf09e3b9bb524 (diff)
downloadfreebsd-ports-graphics-cf5ce99a0b2df38416139487a238cc60fe016cca.tar.gz
freebsd-ports-graphics-cf5ce99a0b2df38416139487a238cc60fe016cca.tar.zst
freebsd-ports-graphics-cf5ce99a0b2df38416139487a238cc60fe016cca.zip
Unset mark_dirs just in case the user has it in their zshenv.
Don't USE_LDCONFIG if WITH_ZSH_STATIC.
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index c2c32cc6e4e..70fc95fe1b1 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -26,7 +26,9 @@ USE_BZIP2= yes
USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 autoheader:262
GNU_CONFIGURE= yes
+.if !defined(WITH_ZSH_STATIC)
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
+.endif
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -150,7 +152,7 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/zsh) > ${SHELLS}
@${RM} ${SHELLS}.bak
@${PREFIX}/bin/zsh -fc ' \
- setopt extendedglob; \
+ setopt extendedglob nomark_dirs; \
for i in ${DATADIR}/${ZSH_VER}/functions/**/*(/) ; do \
zcompile -U -M $$i.zwc $$i/*~*.zwc(^/) ; \
${CHMOD} 644 $$i.zwc ; \