aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2015-02-19 23:59:54 +0800
committerehaupt <ehaupt@FreeBSD.org>2015-02-19 23:59:54 +0800
commitd96a742627d200d4a95b4cbee6a98cab50e153e3 (patch)
tree915ab4f465be50ab0656894c7e2714452519e3a7 /shells
parentc91993da33303faf36cbbdeba03bf38dae4b7707 (diff)
downloadfreebsd-ports-graphics-d96a742627d200d4a95b4cbee6a98cab50e153e3.tar.gz
freebsd-ports-graphics-d96a742627d200d4a95b4cbee6a98cab50e153e3.tar.zst
freebsd-ports-graphics-d96a742627d200d4a95b4cbee6a98cab50e153e3.zip
Ports should not change their pkgname depending on options. Change the way how
the slave port is handled. PR: 197818 Submitted by: mat
Diffstat (limited to 'shells')
-rw-r--r--shells/bash-static/Makefile2
-rw-r--r--shells/bash/Makefile9
2 files changed, 8 insertions, 3 deletions
diff --git a/shells/bash-static/Makefile b/shells/bash-static/Makefile
index 363a823cd52..87482ecf439 100644
--- a/shells/bash-static/Makefile
+++ b/shells/bash-static/Makefile
@@ -5,4 +5,6 @@ MASTERDIR= ${.CURDIR}/../../shells/bash
OPTIONS_SLAVE= STATIC
+PKGNAMESUFFIX= -static
+
.include "${MASTERDIR}/Makefile"
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 3a3577d4ce7..4830ad82c7b 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -56,6 +56,12 @@ CONFIGURE_ARGS+= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins
+.if empty(PKGNAMESUFFIX)
+CONFLICTS+= bash-static-[0-9]*
+.else
+CONFLICTS+= bash-[0-9]*
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPORTFUNCTIONS}
@@ -66,11 +72,8 @@ CFLAGS+= -DIMPORT_FUNCTIONS_DEF=0
.if ${PORT_OPTIONS:MSTATIC} || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:tl} != "no")
CONFIGURE_ARGS+= --enable-static-link
-PKGNAMESUFFIX= -static
-CONFLICTS+= bash-[0-9]*
.else
CONFIGURE_ARGS+= --disable-static-link
-CONFLICTS+= bash-static-[0-9]*
.endif
post-patch: