aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-03-20 00:30:56 +0800
committerjgh <jgh@FreeBSD.org>2012-03-20 00:30:56 +0800
commite9c6ca6ef962aab78e9649f7eb213f65a4707866 (patch)
tree78413e5f1eb453728ebbaaca33ffc1dd1f379d09 /shells
parentd82843c8f922fdde1cdbab0d0136617593eb8550 (diff)
downloadfreebsd-ports-graphics-e9c6ca6ef962aab78e9649f7eb213f65a4707866.tar.gz
freebsd-ports-graphics-e9c6ca6ef962aab78e9649f7eb213f65a4707866.tar.zst
freebsd-ports-graphics-e9c6ca6ef962aab78e9649f7eb213f65a4707866.zip
- remove invalid post-deinstall target
PR: ports/166093 Submitted by: jgh@ Approved by: maintainer, rfarmer@predatorlabs.net Feature safe: yes
Diffstat (limited to 'shells')
-rw-r--r--shells/fish/Makefile8
-rw-r--r--shells/fish/pkg-deinstall7
2 files changed, 8 insertions, 7 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index f6e501e0817..fb478a1e9fe 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fish
PORTVERSION= 1.23.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= shells
MASTER_SITES= SF
@@ -78,10 +78,4 @@ post-install:
${ECHO_CMD} '${PREFIX}/bin/${PORTNAME}' >> /etc/shells; \
fi
-post-deinstall:
- ${CP} /etc/shells /etc/shells.bak
- ${GREP} -v '${PREFIX}/bin/${PORTNAME}' /etc/shells.bak \
- >> /etc/shells
- ${RM} -f /etc/shells.bak
-
.include <bsd.port.post.mk>
diff --git a/shells/fish/pkg-deinstall b/shells/fish/pkg-deinstall
new file mode 100644
index 00000000000..a3c046a0658
--- /dev/null
+++ b/shells/fish/pkg-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ /bin/cp /etc/shells /etc/shells.bak
+ /usr/bin/grep -v '/usr/local/bin/fish' /etc/shells.bak >> /etc/shells
+ /bin/rm -f /etc/shells.bak
+fi