aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/boxbackup
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-03-14 01:19:14 +0800
committerbarner <barner@FreeBSD.org>2005-03-14 01:19:14 +0800
commitf7cc67210f39d09b6e8ab496b320e5a525b36f24 (patch)
tree99a6f21e3d8a9766a34ebaf1fcc96f83bfb8073f /sysutils/boxbackup
parentf9dddf06c58269bd78b5c13fc27bb825e95570df (diff)
downloadfreebsd-ports-graphics-f7cc67210f39d09b6e8ab496b320e5a525b36f24.tar.gz
freebsd-ports-graphics-f7cc67210f39d09b6e8ab496b320e5a525b36f24.tar.zst
freebsd-ports-graphics-f7cc67210f39d09b6e8ab496b320e5a525b36f24.zip
- Avoid hardcoding path to perl binary
- Point port to OpenSSL installation. This fixes the build on systems where _only_ the OpenSSL library from the ports collection is available. PR: ports/78192 Submitted by: maintainer Approved by: arved (mentor), maintainer timeout (9 days): I replaced the fix from the PR with an superior one
Diffstat (limited to 'sysutils/boxbackup')
-rw-r--r--sysutils/boxbackup/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/sysutils/boxbackup/Makefile b/sysutils/boxbackup/Makefile
index ee2994cdd70..9c1eb6d1a1b 100644
--- a/sysutils/boxbackup/Makefile
+++ b/sysutils/boxbackup/Makefile
@@ -23,6 +23,7 @@ COMMENT= An open source, completely automatic on-line backup system for UNIX
USE_OPENSSL= yes
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= openssl:${OPENSSLBASE}
USE_REINPLACE= yes
USE_RC_SUBR= yes
USE_PERL5= yes
@@ -82,6 +83,10 @@ post-patch:
${WRKSRC}/bbstored.sh
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' <${FILESDIR}/bbackupd.sh >\
${WRKSRC}/bbackupd.sh
+ @${FIND} ${WRKSRC} -name "*.pl" -exec \
+ ${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},g' {} \;
+ @${REINPLACE_CMD} -e 's, perl , ${PERL} ,' \
+ ${WRKSRC}/infrastructure/makebuildenv.pl
.if defined(CLIENT_ONLY) || !defined(SERVER_ONLY)
@${CAT} ${FILESDIR}/pkg-message.client >> ${PKGMESSAGE}
.endif