aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dmidecode
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-05-21 19:18:57 +0800
committerbf <bf@FreeBSD.org>2011-05-21 19:18:57 +0800
commit80316b21eadf7e1c974283950784a314a57b3f66 (patch)
tree73b1450cdd037f962f6ec7e72a77eafb4a9d1806 /sysutils/dmidecode
parentddbbc398fd454b0e1307efe98a519163739af201 (diff)
downloadfreebsd-ports-graphics-80316b21eadf7e1c974283950784a314a57b3f66.tar.gz
freebsd-ports-graphics-80316b21eadf7e1c974283950784a314a57b3f66.tar.zst
freebsd-ports-graphics-80316b21eadf7e1c974283950784a314a57b3f66.zip
Update to 2.11, plus two subsequent changes from
dmidecode CVS that add support for SMBIOS 2.7.1 and fix boundary checks of memory array location codes PR: 155664 Submitted by: bf Approved by: maintainer timeout
Diffstat (limited to 'sysutils/dmidecode')
-rw-r--r--sysutils/dmidecode/Makefile23
-rw-r--r--sysutils/dmidecode/distinfo4
-rw-r--r--sysutils/dmidecode/files/patch-Makefile19
-rw-r--r--sysutils/dmidecode/files/patch-dmidecode.c100
4 files changed, 124 insertions, 22 deletions
diff --git a/sysutils/dmidecode/Makefile b/sysutils/dmidecode/Makefile
index 3a8f53930b6..8e531ec9a3c 100644
--- a/sysutils/dmidecode/Makefile
+++ b/sysutils/dmidecode/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dmidecode
-PORTVERSION= 2.10
+PORTVERSION= 2.11
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -18,27 +18,22 @@ COMMENT= A tool for dumping DMI (SMBIOS) contents in human-readable format
ONLY_FOR_ARCHS= i386 amd64 ia64
USE_BZIP2= yes
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" DOCSDIR="${DOCSDIR}"
+MAKE_ENV+= DOCSDIR="${DOCSDIR}" LDFLAGS="${LDFLAGS}"
+LICENSE= GPLv2
-PORTDOCS= AUTHORS CHANGELOG README
-
-post-patch:
.if defined(NOPORTDOCS)
+post-patch:
@${REINPLACE_CMD} -e '/^install.*:/s,install-doc,,' ${WRKSRC}/Makefile
-.endif
-post-install:
-.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-.endfor
+.else
+PORTDOCS= AUTHORS CHANGELOG README
.endif
-.include <bsd.port.pre.mk>
-
MAN8= dmidecode.8
PLIST_FILES= sbin/dmidecode
+
+.include <bsd.port.pre.mk>
+
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
MAN8+= biosdecode.8 ownership.8 vpddecode.8
PLIST_FILES+= sbin/biosdecode sbin/ownership sbin/vpddecode
diff --git a/sysutils/dmidecode/distinfo b/sysutils/dmidecode/distinfo
index e3996b9d402..c64aaa198ac 100644
--- a/sysutils/dmidecode/distinfo
+++ b/sysutils/dmidecode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmidecode-2.10.tar.bz2) = 4d74a3e93353320317a424816f9a045df06d9ed4b5b80881e16fdfcc74c9e2c0
-SIZE (dmidecode-2.10.tar.bz2) = 51904
+SHA256 (dmidecode-2.11.tar.bz2) = 6da5643479b3b591b71a91122a25b89b77920b66e1ad0a5162d3c75b50423b51
+SIZE (dmidecode-2.11.tar.bz2) = 54537
diff --git a/sysutils/dmidecode/files/patch-Makefile b/sysutils/dmidecode/files/patch-Makefile
index 719e3abaadf..7a0d99e3a55 100644
--- a/sysutils/dmidecode/files/patch-Makefile
+++ b/sysutils/dmidecode/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig Tue Feb 7 09:45:21 2006
-+++ Makefile Tue Feb 7 09:47:11 2006
-@@ -8,25 +8,25 @@
- # Licensed under the GNU Public License.
+--- Makefile.orig 2010-10-11 10:08:16.000000000 -0400
++++ Makefile 2011-03-18 12:55:54.000000000 -0400
+@@ -12,30 +12,30 @@
+ # (at your option) any later version.
#
-CC = gcc
@@ -20,7 +20,7 @@
# Pass linker flags here
-LDFLAGS =
-+LDFLAGS+=
++LDFLAGS+= $(CFLAGS)
DESTDIR =
-prefix = /usr/local
@@ -33,4 +33,11 @@
+docdir = $(DOCSDIR)
INSTALL := install
- INSTALL_DATA := $(INSTALL) -m 644
+-INSTALL_DATA := $(INSTALL) -m 644
++INSTALL_DATA := $(BSD_INSTALL_DATA)
+ INSTALL_DIR := $(INSTALL) -m 755 -d
+-INSTALL_PROGRAM := $(INSTALL) -m 755
++INSTALL_PROGRAM := $(BSD_INSTALL_PROGRAM)
+ RM := rm -f
+
+ # BSD make provides $MACHINE, but GNU make doesn't
diff --git a/sysutils/dmidecode/files/patch-dmidecode.c b/sysutils/dmidecode/files/patch-dmidecode.c
new file mode 100644
index 00000000000..faafaecd723
--- /dev/null
+++ b/sysutils/dmidecode/files/patch-dmidecode.c
@@ -0,0 +1,100 @@
+diff -u dmidecode.c dmidecode.c
+--- dmidecode.c 2011/01/25 16:19:42 1.167
++++ dmidecode.c 2011/04/20 14:37:03 1.168
+@@ -707,6 +707,8 @@
+ { 0x3A, "Athlon II Dual-Core M" },
+ { 0x3B, "Opteron 6100" },
+ { 0x3C, "Opteron 4100" },
++ { 0x3D, "Opteron 6200" },
++ { 0x3E, "Opteron 4200" },
+
+ { 0x40, "MIPS" },
+ { 0x41, "MIPS R4000" },
+@@ -714,6 +716,10 @@
+ { 0x43, "MIPS R4400" },
+ { 0x44, "MIPS R4600" },
+ { 0x45, "MIPS R10000" },
++ { 0x46, "C-Series" },
++ { 0x47, "E-Series" },
++ { 0x48, "S-Series" },
++ { 0x49, "G-Series" },
+
+ { 0x50, "SPARC" },
+ { 0x51, "SuperSPARC" },
+@@ -997,7 +1003,8 @@
+ sig = 1;
+ else if ((type >= 0x18 && type <= 0x1D) /* AMD */
+ || type == 0x1F /* AMD */
+- || (type >= 0x38 && type <= 0x3C) /* AMD */
++ || (type >= 0x38 && type <= 0x3E) /* AMD */
++ || (type >= 0x46 && type <= 0x49) /* AMD */
+ || (type >= 0x83 && type <= 0x8F) /* AMD */
+ || (type >= 0xB6 && type <= 0xB7) /* AMD */
+ || (type >= 0xE6 && type <= 0xEF)) /* AMD */
+@@ -1143,10 +1150,20 @@
+ "Socket LGA1156",
+ "Socket LGA1567",
+ "Socket PGA988A",
+- "Socket BGA1288" /* 0x20 */
++ "Socket BGA1288",
++ "Socket rPGA988B",
++ "Socket BGA1023",
++ "Socket BGA1024",
++ "Socket BGA1155",
++ "Socket LGA1356",
++ "Socket LGA2011",
++ "Socket FS1",
++ "Socket FS2",
++ "Socket FM1",
++ "Socket FM2" /* 0x2A */
+ };
+
+- if (code >= 0x01 && code <= 0x20)
++ if (code >= 0x01 && code <= 0x2A)
+ return upgrade[code - 0x01];
+ return out_of_spec;
+ }
+@@ -1493,10 +1510,11 @@
+ "24-way Set-associative",
+ "32-way Set-associative",
+ "48-way Set-associative",
+- "64-way Set-associative" /* 0x0D */
++ "64-way Set-associative",
++ "20-way Set-associative" /* 0x0E */
+ };
+
+- if (code >= 0x01 && code <= 0x0D)
++ if (code >= 0x01 && code <= 0x0E)
+ return type[code - 0x01];
+ return out_of_spec;
+ }
+@@ -1660,12 +1678,18 @@
+ "PCI Express 2 x2",
+ "PCI Express 2 x4",
+ "PCI Express 2 x8",
+- "PCI Express 2 x16", /* 0xB0 */
++ "PCI Express 2 x16",
++ "PCI Express 3",
++ "PCI Express 3 x1",
++ "PCI Express 3 x2",
++ "PCI Express 3 x4",
++ "PCI Express 3 x8",
++ "PCI Express 3 x16" /* 0xB6 */
+ };
+
+ if (code >= 0x01 && code <= 0x13)
+ return type[code - 0x01];
+- if (code >= 0xA0 && code <= 0xB0)
++ if (code >= 0xA0 && code <= 0xB6)
+ return type_0xA0[code - 0xA0];
+ return out_of_spec;
+ }
+@@ -2100,7 +2124,7 @@
+
+ if (code >= 0x01 && code <= 0x0A)
+ return location[code - 0x01];
+- if (code >= 0xA0 && code <= 0xA4)
++ if (code >= 0xA0 && code <= 0xA3)
+ return location_0xA0[code - 0xA0];
+ return out_of_spec;
+ }