aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fcron/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-11-13 05:23:49 +0800
committersem <sem@FreeBSD.org>2005-11-13 05:23:49 +0800
commitfdc68492b00f2bc438ef15f1b57792f53a7feaec (patch)
treecd88748e6eddd531ba4158b2da08d53b23301489 /sysutils/fcron/Makefile
parent673753cb6d6b8fccfd06844f174dda3c9a444dfb (diff)
downloadfreebsd-ports-graphics-fdc68492b00f2bc438ef15f1b57792f53a7feaec.tar.gz
freebsd-ports-graphics-fdc68492b00f2bc438ef15f1b57792f53a7feaec.tar.zst
freebsd-ports-graphics-fdc68492b00f2bc438ef15f1b57792f53a7feaec.zip
- Fix fcron crashing with disabling of fcrondyn
- Get rid of unnessesary patch PR: ports/88883 Submitted by: maintainer
Diffstat (limited to 'sysutils/fcron/Makefile')
-rw-r--r--sysutils/fcron/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/sysutils/fcron/Makefile b/sysutils/fcron/Makefile
index 106beb6cc7c..5a9dd6aee8a 100644
--- a/sysutils/fcron/Makefile
+++ b/sysutils/fcron/Makefile
@@ -8,7 +8,7 @@
PORTNAME= fcron
PORTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://fcron.free.fr/
@@ -20,17 +20,17 @@ COMMENT= A periodic command scheduler
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--with-rootname=root --with-rootgroup=wheel \
- --with-docdir=${DOCSDIR}
+ --with-docdir=${DOCSDIR} --with-fcrondyn=no
WRKSRC= ${WRKDIR}/fcron-${PORTVERSION}
USE_RC_SUBR= fcron
SUB_FILES= pkg-message
-MAN1= fcrondyn.1 fcrontab.1
+MAN1= fcrontab.1
MAN5= fcron.conf.5 fcrontab.5
MAN8= fcron.8
@@ -43,7 +43,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fcron ${PREFIX}/sbin
${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrontab ${PREFIX}/bin
${INSTALL_PROGRAM} -g fcron -m 4110 ${WRKSRC}/fcronsighup ${PREFIX}/bin
- ${INSTALL_PROGRAM} -g fcron -o fcron -m 6111 ${WRKSRC}/fcrondyn ${PREFIX}/bin
.for f in fcron.allow fcron.conf fcron.deny
${INSTALL_DATA} -g fcron -m 640 ${WRKSRC}/files/${f} ${PREFIX}/etc/${f}.dist
.endfor