aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/file/Makefile
diff options
context:
space:
mode:
authorokazaki <okazaki@FreeBSD.org>2002-05-28 17:46:36 +0800
committerokazaki <okazaki@FreeBSD.org>2002-05-28 17:46:36 +0800
commita54e011e052250511c009840bec606ffd519f5c3 (patch)
tree0379ea07a23715dc137be0298b8a9ae6fd1ae06a /sysutils/file/Makefile
parent7f12d4f1a4f0ff0677f20305595b834af3a8cca7 (diff)
downloadfreebsd-ports-graphics-a54e011e052250511c009840bec606ffd519f5c3.tar.gz
freebsd-ports-graphics-a54e011e052250511c009840bec606ffd519f5c3.tar.zst
freebsd-ports-graphics-a54e011e052250511c009840bec606ffd519f5c3.zip
Upgrade to file-3.38.
Add the post-extract: target to adjust the timestamp of some files. These rules are required to suppress invocations of aclocal, automake, autoconf and autoheader at `make build' and `make install'. Approved by: maintainer
Diffstat (limited to 'sysutils/file/Makefile')
-rw-r--r--sysutils/file/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/file/Makefile b/sysutils/file/Makefile
index 900cdfbe6ba..f748c85d0d5 100644
--- a/sysutils/file/Makefile
+++ b/sysutils/file/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= file
-PORTVERSION= 3.37
+PORTVERSION= 3.38
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.astron.com/pub/file/ \
ftp://ftp.gw.com/mirrors/pub/unix/file/ \
@@ -20,4 +20,9 @@ CONFIGURE_ARGS= --enable-fsect-man5
MAN1= file.1
MAN5= magic.5
+post-extract:
+ ${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/aclocal.m4
+ ${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/Makefile.in
+ ${TOUCH} ${TOUCH_FLAGS} ${WRKSRC}/stamp-h.in
+
.include <bsd.port.mk>