aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/firstboot-growfs
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-12-24 12:50:16 +0800
committerswills <swills@FreeBSD.org>2014-12-24 12:50:16 +0800
commit084dca3998db5e6db469dc8d60e8b1a9dcc8295e (patch)
treeaed146d1d816f439832bca9a46cd447061e34afd /sysutils/firstboot-growfs
parentb444b9699ce870f4a2d7ffe45b15c13c53260793 (diff)
downloadfreebsd-ports-graphics-084dca3998db5e6db469dc8d60e8b1a9dcc8295e.tar.gz
freebsd-ports-graphics-084dca3998db5e6db469dc8d60e8b1a9dcc8295e.tar.zst
freebsd-ports-graphics-084dca3998db5e6db469dc8d60e8b1a9dcc8295e.zip
sysutils/firstboot-growfs: revive
Revive this port as it will still be useful until the similar functionality in base is more widely available, take ownership.
Diffstat (limited to 'sysutils/firstboot-growfs')
-rw-r--r--sysutils/firstboot-growfs/Makefile26
-rw-r--r--sysutils/firstboot-growfs/files/firstboot_growfs.in58
-rw-r--r--sysutils/firstboot-growfs/pkg-descr4
3 files changed, 88 insertions, 0 deletions
diff --git a/sysutils/firstboot-growfs/Makefile b/sysutils/firstboot-growfs/Makefile
new file mode 100644
index 00000000000..77dd64dfe1d
--- /dev/null
+++ b/sysutils/firstboot-growfs/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= firstboot-growfs
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Expand / when the system first boots
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_RC_SUBR= firstboot_growfs
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 902504 || ( ${OSVERSION} >= 1000000 && ${OSVERSION} < 1000100 ) || ( ${OSVERSION} >= 1000500 && ${OSVERSION} < 1000501 ) || (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100001 )
+IGNORE= first boot rc.d scripts not supported on this version of FreeBSD
+.endif
+
+do-fetch do-install:
+ @${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/firstboot-growfs/files/firstboot_growfs.in b/sysutils/firstboot-growfs/files/firstboot_growfs.in
new file mode 100644
index 00000000000..7e56684cd67
--- /dev/null
+++ b/sysutils/firstboot-growfs/files/firstboot_growfs.in
@@ -0,0 +1,58 @@
+#!/bin/sh
+
+# $FreeBSD$
+# KEYWORD: firstboot
+# PROVIDE: firstboot_growfs
+# REQUIRE: NETWORKING
+# BEFORE: LOGIN
+
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf (in the disk
+# image, since this only runs on the first boot) to enable this:
+#
+# firstboot_growfs_enable="YES"
+
+. /etc/rc.subr
+
+: ${firstboot_growfs_enable:="NO"}
+: ${firstboot_growfs_fs:="/"}
+
+name="firstboot_growfs"
+rcvar=firstboot_growfs_enable
+start_cmd="firstboot_growfs_run"
+stop_cmd=":"
+
+firstboot_growfs_run()
+{
+ local FSTYPE DISK GPTLABEL GPART GDISK GPARTNO
+
+ FSTYPE=`mount -p | awk "{ if (\\$2 == \"${firstboot_growfs_fs}\") print \\$3 }"`
+ case ${FSTYPE} in
+ ufs)
+ ;;
+ *)
+ echo "${firstboot_growfs_fs} is not a UFS volume, cannot resize"
+ ;;
+ esac
+
+ DISK=`mount -p | awk "{ if (\\$2 == \"${firstboot_growfs_fs}\") print \\$1 }"`
+ case ${DISK} in
+ /dev/gpt/*)
+ GPTLABEL=${DISK##/dev/gpt/}
+ ;;
+ *)
+ echo "${firstboot_growfs_fs} is not on a GPT disk, cannot resize"
+ return 0
+ ;;
+ esac
+
+ GPART=`glabel status -s | awk "{ if (\\$1 == \"gpt/${GPTLABEL}\") print \\$3 }"`
+ GDISK=${GPART%p*}
+ GPARTNO=${GPART##*p}
+
+ gpart recover ${GDISK}
+ gpart resize -i ${GPARTNO} ${GDISK}
+ growfs -y ${firstboot_growfs_fs}
+}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/sysutils/firstboot-growfs/pkg-descr b/sysutils/firstboot-growfs/pkg-descr
new file mode 100644
index 00000000000..1c36bcfe9e0
--- /dev/null
+++ b/sysutils/firstboot-growfs/pkg-descr
@@ -0,0 +1,4 @@
+When the system first boots, resize the (GPT) partition holding the root
+filesystem, then resize the (UFS) root filesystem. This is intended to be
+used in virtual machines where a VM image is built with one size but may
+be launched onto a larger disk.