aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnomecontrolcenter2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-29 20:55:02 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-29 20:55:02 +0800
commitc6ee7e02e1c9832dae2d2724812972d7b1bed68e (patch)
treea06060e41131e999c5b8eca2d2c023fe22b76d51 /sysutils/gnomecontrolcenter2
parent236c8ea5bf0e0c13d516020f1e5a28a6dd22c6ec (diff)
downloadfreebsd-ports-graphics-c6ee7e02e1c9832dae2d2724812972d7b1bed68e.tar.gz
freebsd-ports-graphics-c6ee7e02e1c9832dae2d2724812972d7b1bed68e.tar.zst
freebsd-ports-graphics-c6ee7e02e1c9832dae2d2724812972d7b1bed68e.zip
Don't try to free() statically allocated array.
PR: 36426 Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Diffstat (limited to 'sysutils/gnomecontrolcenter2')
-rw-r--r--sysutils/gnomecontrolcenter2/Makefile2
-rw-r--r--sysutils/gnomecontrolcenter2/files/patch-capplets::theme-switcher::lister.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/sysutils/gnomecontrolcenter2/Makefile b/sysutils/gnomecontrolcenter2/Makefile
index 573ed5c088f..afd41e098a0 100644
--- a/sysutils/gnomecontrolcenter2/Makefile
+++ b/sysutils/gnomecontrolcenter2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomecontrolcenter
PORTVERSION= 1.4.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/control-center
diff --git a/sysutils/gnomecontrolcenter2/files/patch-capplets::theme-switcher::lister.c b/sysutils/gnomecontrolcenter2/files/patch-capplets::theme-switcher::lister.c
new file mode 100644
index 00000000000..ce817037012
--- /dev/null
+++ b/sysutils/gnomecontrolcenter2/files/patch-capplets::theme-switcher::lister.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- capplets/theme-switcher/lister.c 2002/03/29 12:43:59 1.1
++++ capplets/theme-switcher/lister.c 2002/03/29 12:45:18
+@@ -115,8 +115,7 @@
+ char *errstring = NULL;
+ int out_fd;
+ #ifndef HAVE_GETLINE
+- char line[1024];
+- char *lineptr = line;
++ char *lineptr = (char *)malloc(1024);
+ #else
+ char *lineptr = NULL;
+ #endif