aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hdup/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-03-14 01:11:48 +0800
committersem <sem@FreeBSD.org>2005-03-14 01:11:48 +0800
commite4cf8453a9825c71da0368baa33df51a249134fa (patch)
treeefdfada36b316b218d7fe511cf6021ef6300318a /sysutils/hdup/Makefile
parent472f1c88e90ab90c5c2bd6908e60cd27a8b2322c (diff)
downloadfreebsd-ports-graphics-e4cf8453a9825c71da0368baa33df51a249134fa.tar.gz
freebsd-ports-graphics-e4cf8453a9825c71da0368baa33df51a249134fa.tar.zst
freebsd-ports-graphics-e4cf8453a9825c71da0368baa33df51a249134fa.zip
hdup is a little, spiffy, backup tool
Diffstat (limited to 'sysutils/hdup/Makefile')
-rw-r--r--sysutils/hdup/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/hdup/Makefile b/sysutils/hdup/Makefile
new file mode 100644
index 00000000000..fac45fd7c2b
--- /dev/null
+++ b/sysutils/hdup/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: hdup
+# Date created: 6 March 2005
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hdup
+PORTVERSION= 2.0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.miek.nl/projects/hdup2/
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= The little, spiffy, backup tool
+
+WRKSRC= ${WRKDIR}/hdup2
+
+OPTIONS= GNUTAR_PORT "Build with the newest GNU tar from ports" no
+
+BUILD_DEPENDS= mcrypt:${PORTSDIR}/security/mcrypt
+RUN_DEPENDS= mcrypt:${PORTSDIR}/security/mcrypt \
+ gpg:${PORTSDIR}/security/gnupg \
+ lzop:${PORTSDIR}/archivers/lzop
+
+USE_REINPLACE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_AUTOCONF_VER= 259
+
+MAN1= hdup.1
+MAN5= hdup.conf.5
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GNUTAR_PORT)
+BUILD_DEPENDS+= ${LOCALBASE}/gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS+= ${LOCALBASE}/gtar:${PORTSDIR}/archivers/gtar
+GNUTAR= ${LOCALBASE}/bin/gtar
+.elif ${OSVERSION} < 502110
+GNUTAR= /usr/bin/tar
+.else
+# bsdtar appeared
+GNUTAR= /usr/bin/gtar
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's#%%GNUTAR%%#${GNUTAR}#g' ${WRKSRC}/src/hdup.h
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/doc/FAQ.html ${DOCSDIR}; \
+ ${MKDIR} ${EXAMPLESDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>