aboutsummaryrefslogtreecommitdiffstats
path: generated by cgit (git 2.34.1) at 2024-12-19 12:01:08 +0800
ass='cgit-panel'>diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
committerade <ade@FreeBSD.org>2006-02-23 18:40:44 +0800
commitda880765886f48c0ac8fd253e5601d04ea853215 (patch)
tree55155f50e8a40ea2e2a16e2331e8cbb919b7d04f /sysutils/knutclient
parentba4beb1ea11e6147a9b30969be42685d1c709e56 (diff)
downloadfreebsd-ports-graphics-da880765886f48c0ac8fd253e5601d04ea853215.tar.gz
freebsd-ports-graphics-da880765886f48c0ac8fd253e5601d04ea853215.tar.zst
freebsd-ports-graphics-da880765886f48c0ac8fd253e5601d04ea853215.zip
Conversion to a single libtool environment.
Approved by: portmgr (kris)
Diffstat (limited to 'sysutils/knutclient')
-rw-r--r--sysutils/knutclient/Makefile5
-rw-r--r--sysutils/knutclient/files/patch-configure37
2 files changed, 39 insertions, 3 deletions
diff --git a/sysutils/knutclient/Makefile b/sysutils/knutclient/Makefile
index f17f617971a..cdf10b52da8 100644
--- a/sysutils/knutclient/Makefile
+++ b/sysutils/knutclient/Makefile
@@ -17,9 +17,8 @@ COMMENT= A visual client for UPS system NUT
USE_KDELIBS_VER=3
USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-mt \
- --program-transform-name=''
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ARGS= --enable-mt --program-transform-name=''
post-patch:
@${REINPLACE_CMD} -E \
diff --git a/sysutils/knutclient/files/patch-configure b/sysutils/knutclient/files/patch-configure
new file mode 100644
index 00000000000..0c9134f4df0
--- /dev/null
+++ b/sysutils/knutclient/files/patch-configure
@@ -0,0 +1,37 @@
+--- configure.orig Sun Dec 15 15:33:40 2002
++++ configure Sat Feb 18 22:56:35 2006
+@@ -5865,15 +5865,2 @@
+
+-# Actually configure libtool. ac_aux_dir is where install-sh is found.
+-AR="$AR" LTCC="$CC" CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
+-MAGIC_CMD="$MAGIC_CMD" LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+-LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" STRIP="$STRIP" \
+-AS="$AS" DLLTOOL="$DLLTOOL" OBJDUMP="$OBJDUMP" \
+-objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
+-deplibs_check_method="$deplibs_check_method" file_magic_cmd="$file_magic_cmd" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify --build="$build" $ac_aux_dir/ltmain.sh $host \
+-|| { { echo "$as_me:$LINENO: error: libtool configure failed" >&5
+-echo "$as_me: error: libtool configure failed" >&2;}
+- { (exit 1); exit 1; }; }
+-
+ # Reload cache, that may have been modified by ltconfig
+@@ -5910,18 +5897,2 @@
+ LIBTOOL_DEPS=$LIBTOOL_DEPS" $ac_aux_dir/ltcf-cxx.sh"
+-lt_save_CC="$CC"
+-lt_save_CFLAGS="$CFLAGS"
+-AR="$AR" LTCC="$CC" CC="$CXX" CXX="$CXX" CFLAGS="$CXXFLAGS" CPPFLAGS="$CPPFLAGS" \
+-MAGIC_CMD="$MAGIC_CMD" LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+-LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" STRIP="$STRIP" \
+-AS="$AS" DLLTOOL="$DLLTOOL" OBJDUMP="$OBJDUMP" \
+-objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
+-deplibs_check_method="$deplibs_check_method" \
+-file_magic_cmd="$file_magic_cmd" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig -o libtool $libtool_flags \
+---build="$build" --add-tag=CXX $ac_aux_dir/ltcf-cxx.sh $host \
+-|| { { echo "$as_me:$LINENO: error: libtool tag configuration failed" >&5
+-echo "$as_me: error: libtool tag configuration failed" >&2;}
+- { (exit 1); exit 1; }; }
+-CC="$lt_save_CC"
+-CFLAGS="$lt_save_CFLAGS"
+