aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pfstat
diff options
context:
space:
mode:
authormlaier <mlaier@FreeBSD.org>2006-12-16 09:58:38 +0800
committermlaier <mlaier@FreeBSD.org>2006-12-16 09:58:38 +0800
commit36061d737a2be54011c840521b840ba3bb073c0a (patch)
tree41f1903e6a772f27d6a5e8811faa5f69e27bbd4e /sysutils/pfstat
parented31b15c79ed5c6c8113311064964f2599bcc5d4 (diff)
downloadfreebsd-ports-graphics-36061d737a2be54011c840521b840ba3bb073c0a.tar.gz
freebsd-ports-graphics-36061d737a2be54011c840521b840ba3bb073c0a.tar.zst
freebsd-ports-graphics-36061d737a2be54011c840521b840ba3bb073c0a.zip
Make pfstat work on non-ALTQ kernels. Patch submitted upstream, but for now
patch around. Also fix a typo and email markup, both spotted by Pav. Reported by: Lars Wittebrood Approved by: pav
Diffstat (limited to 'sysutils/pfstat')
-rw-r--r--sysutils/pfstat/Makefile6
-rw-r--r--sysutils/pfstat/files/patch-pf.c17
2 files changed, 18 insertions, 5 deletions
diff --git a/sysutils/pfstat/Makefile b/sysutils/pfstat/Makefile
index 704f5a565af..5111081a61f 100644
--- a/sysutils/pfstat/Makefile
+++ b/sysutils/pfstat/Makefile
@@ -7,13 +7,13 @@
PORTNAME= pfstat
PORTVERSION= 2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils net
MASTER_SITES= http://www.benzedrine.cx/
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= mlaier@freebsd.org
-COMMENT= Utility to render grafical statistics for pf
+MAINTAINER= mlaier@FreeBSD.org
+COMMENT= Utility to render graphical statistics for pf
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
diff --git a/sysutils/pfstat/files/patch-pf.c b/sysutils/pfstat/files/patch-pf.c
index 71e897e8d49..92abe2b69e4 100644
--- a/sysutils/pfstat/files/patch-pf.c
+++ b/sysutils/pfstat/files/patch-pf.c
@@ -1,6 +1,19 @@
--- pf.c.orig Thu May 11 23:41:07 2006
-+++ pf.c Fri Jul 7 21:49:20 2006
-@@ -144,23 +144,24 @@
++++ pf.c Mon Dec 11 21:08:31 2006
+@@ -67,10 +67,8 @@
+
+ /* first, find out how many queues there are */
+ memset(&pa, 0, sizeof(pa));
+- if (ioctl(fd, DIOCGETALTQS, &pa)) {
+- fprintf(stderr, "ioctl: DIOCGETALTQS: %s\n", strerror(errno));
+- return (1);
+- }
++ if (ioctl(fd, DIOCGETALTQS, &pa))
++ return (0);
+ mnr = pa.nr;
+
+ /* fetch each of those queues */
+@@ -144,23 +142,24 @@
query_ifaces(int fd, void (*cb)(int, const char *, int, double))
{
struct pfioc_iface io;