aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pmt
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-01-07 02:46:09 +0800
committerglarkin <glarkin@FreeBSD.org>2010-01-07 02:46:09 +0800
commitbf6814ec7202b39960fb68fe8587cde9174f87e4 (patch)
treebbe492ffd17af6c15fe2c798f8cdc2e821133a5f /sysutils/pmt
parent13d164d27536a927845cf00ed5c10f91fb5e0598 (diff)
downloadfreebsd-ports-graphics-bf6814ec7202b39960fb68fe8587cde9174f87e4.tar.gz
freebsd-ports-graphics-bf6814ec7202b39960fb68fe8587cde9174f87e4.tar.zst
freebsd-ports-graphics-bf6814ec7202b39960fb68fe8587cde9174f87e4.zip
- Fixed the build on 8.0. POSIX namespace changes in sys/time.h caused
an implicit function declaration for gettimeofday. Patched by: till plewe <till.plewe@gmail.com>
Diffstat (limited to 'sysutils/pmt')
-rw-r--r--sysutils/pmt/Makefile6
-rw-r--r--sysutils/pmt/files/extra-patch-config.mak10
2 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/pmt/Makefile b/sysutils/pmt/Makefile
index 3f7859a60a7..d419d436c8f 100644
--- a/sysutils/pmt/Makefile
+++ b/sysutils/pmt/Makefile
@@ -22,4 +22,8 @@ PLIST_FILES= bin/pmt
do-install:
@${CP} ${WRKSRC}/pmt ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800071
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.mak
+.endif
+.include <bsd.port.post.mk>
diff --git a/sysutils/pmt/files/extra-patch-config.mak b/sysutils/pmt/files/extra-patch-config.mak
new file mode 100644
index 00000000000..ebefc54091c
--- /dev/null
+++ b/sysutils/pmt/files/extra-patch-config.mak
@@ -0,0 +1,10 @@
+--- ./config.mak.orig 2010-01-06 08:21:36.000000000 -0500
++++ ./config.mak 2010-01-06 08:21:54.000000000 -0500
+@@ -1,6 +1,6 @@
+ VERSION = 0.2
+ MAKEFLAGS += --print-directory
+-PMT_CFLAGS = -std=c99 -Wall -Werror -pedantic \
++PMT_CFLAGS = -std=c99 -Wall -Werror -pedantic -D__XSI_VISIBLE \
+ -D_POSIX_SOURCE -DVERSION='$(VERSION)' \
+ -I. -Ilibowfat
+