aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/portupgrade
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-02 19:03:25 +0800
committeredwin <edwin@FreeBSD.org>2006-01-02 19:03:25 +0800
commit0401294d1a9fbab07f8c94e4575cdadc41b86d49 (patch)
tree311f7e8e62ad7e97cd409e16aa6289c461484052 /sysutils/portupgrade
parent51dc1295219b8e1c8e2f226377d9be7a540fb4b7 (diff)
downloadfreebsd-ports-graphics-0401294d1a9fbab07f8c94e4575cdadc41b86d49.tar.gz
freebsd-ports-graphics-0401294d1a9fbab07f8c94e4575cdadc41b86d49.tar.zst
freebsd-ports-graphics-0401294d1a9fbab07f8c94e4575cdadc41b86d49.zip
Problem with portupgrade 2.0
Thank you for reporting. I also discovered this problem a few hours ago. The source of this trouble is that the following line exists in MOVED, lang/php4|lang/php4|2003-05-22|re-separated from www/mod_php4 where "moved from" and "moved to" is the same, but portupgrade does not check this case and infinite loop occurs. Fix to this problem will be in the next portupgrade release, but in the meanwhile, whould you commit the following patch, please? PR: ports/91209 Submitted by: KOMATSU Shinichiro <koma2@lovepeers.org>
Diffstat (limited to 'sysutils/portupgrade')
-rw-r--r--sysutils/portupgrade/Makefile2
-rw-r--r--sysutils/portupgrade/files/patch-lib-portsdb.rb16
2 files changed, 17 insertions, 1 deletions
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index ad357afea68..c4ec8d5e9e3 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 2.0.0
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= sysutils
MASTER_SITES= http://dists.lovepeers.org/distfiles/portupgrade/
diff --git a/sysutils/portupgrade/files/patch-lib-portsdb.rb b/sysutils/portupgrade/files/patch-lib-portsdb.rb
new file mode 100644
index 00000000000..2a7d989170a
--- /dev/null
+++ b/sysutils/portupgrade/files/patch-lib-portsdb.rb
@@ -0,0 +1,16 @@
+--- lib/portsdb.rb.orig Mon Jan 2 21:58:23 2006
++++ lib/portsdb.rb Mon Jan 2 21:58:55 2006
+@@ -87,8 +87,11 @@
+ while true
+ if moved = @moved[me]
+ t << moved
+- me = moved.to
+- break if me.nil?
++ if me.nil? or me == moved.to
++ break
++ else
++ me = moved.to
++ end
+ else
+ break
+ end