aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/procenv/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-02-08 01:10:46 +0800
committerpawel <pawel@FreeBSD.org>2014-02-08 01:10:46 +0800
commit136b2b8a761e5b49c79f7c183c005f0d13fb6d92 (patch)
treeac5ee4c7acf25598472cc86ab0c1fce90e7646b3 /sysutils/procenv/Makefile
parent173cd3ce9af509f5ef7405f213b8215aef25689d (diff)
downloadfreebsd-ports-graphics-136b2b8a761e5b49c79f7c183c005f0d13fb6d92.tar.gz
freebsd-ports-graphics-136b2b8a761e5b49c79f7c183c005f0d13fb6d92.tar.zst
freebsd-ports-graphics-136b2b8a761e5b49c79f7c183c005f0d13fb6d92.zip
- Update to version 0.32 [1]
- Support staging - Strip program binary PR: ports/186310 [1] Submitted by: maintainer
Diffstat (limited to 'sysutils/procenv/Makefile')
-rw-r--r--sysutils/procenv/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/sysutils/procenv/Makefile b/sysutils/procenv/Makefile
index 1c3df6c02c0..e92b3289539 100644
--- a/sysutils/procenv/Makefile
+++ b/sysutils/procenv/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= procenv
-PORTVERSION= 0.26
+PORTVERSION= 0.32
CATEGORIES= sysutils
MASTER_SITES= https://launchpad.net/procenv/trunk/${PORTVERSION}/+download/ \
DEBIAN \
@@ -13,14 +13,16 @@ COMMENT= Utility to show process environment
LICENSE= GPLv3
+BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
+
GNU_CONFIGURE= yes
USES= gmake
USE_AUTOTOOLS= aclocal automake
+USE_PERL5_BUILD=yes
-MAN1= procenv.1
-PLIST_FILES= bin/procenv
+PLIST_FILES= bin/procenv \
+ man/man1/procenv.1.gz
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800505
@@ -33,8 +35,11 @@ BROKEN= does not build on old ${OPSYS} versions
# of the build system which may be of interest to those fixing FTBFS
# packages that build correctly locally.
regression-test: build
- cd ${WRKSRC} && ${MAKE} check
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check
test: regression-test
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/procenv
+
.include <bsd.port.post.mk>