aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/pwsafe
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-12-05 11:30:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-12-05 11:30:31 +0800
commit2f396c37e7b03b43844894f5a88acde69ca3397a (patch)
tree259b8b02c782ea0d70699fb07ff81a3fda0712a5 /sysutils/pwsafe
parentcf01907f2f5fa0c36bf615b2b6f4cb1bc29058d6 (diff)
downloadfreebsd-ports-graphics-2f396c37e7b03b43844894f5a88acde69ca3397a.tar.gz
freebsd-ports-graphics-2f396c37e7b03b43844894f5a88acde69ca3397a.tar.zst
freebsd-ports-graphics-2f396c37e7b03b43844894f5a88acde69ca3397a.zip
- Fix X11 libraries dependency handling: this is a better fix to ports/153198
- Add OPTIONS X11: build pwsafe with X11 libraries (default off) - Bump PORTREVISION for dependency change - Cosmetic change PR: ports/162649 Reported by: Jeremie Le Hen <jeremie@le-hen.org> Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 16 days) Feature safe: yes
Diffstat (limited to 'sysutils/pwsafe')
-rw-r--r--sysutils/pwsafe/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/sysutils/pwsafe/Makefile b/sysutils/pwsafe/Makefile
index 65e23f85c63..73dd12cf761 100644
--- a/sysutils/pwsafe/Makefile
+++ b/sysutils/pwsafe/Makefile
@@ -7,30 +7,39 @@
PORTNAME= pwsafe
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://nsd.dyndns.org/pwsafe/releases/
MAINTAINER= donnex@donnex.net
COMMENT= Cmdline program that manages encrypted password databases
-OPTIONS= SETUID "Install setuid pwsafe binary" off
+OPTIONS= SETUID "Install setuid pwsafe binary" off \
+ X11 "Build with X11 libraries" off
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_XORG= ice sm x11 xmu
MAN1= pwsafe.1
PLIST_FILES= bin/pwsafe
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if defined(WITH_X11)
+CONFIGURE_ARGS= --with-x
+USE_XORG= ice sm x11 xmu
+.else
+CONFIGURE_ARGS= ac_cv_have_x="have_x=no" \
+ ac_cv_lib_ICE_IceConnectionNumber=no \
+ ac_cv_lib_X11_XOpenDisplay=no \
+ ac_cv_lib_Xmu_XmuInternAtom=no
+.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pwsafe ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pwsafe.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/pwsafe ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/pwsafe.1 ${PREFIX}/man/man1/
.if defined(WITH_SETUID)
${CHMOD} u+s ${PREFIX}/bin/pwsafe
.endif
-.include <bsd.port.post.mk>
-
+.include <bsd.port.mk>