aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/udfclient
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-07-26 20:15:44 +0800
committervs <vs@FreeBSD.org>2005-07-26 20:15:44 +0800
commit1df94b1eceda769149209bb358fb5efe0c7ffd7f (patch)
treeeeb73bca20c358e2c35a7a5fff23e603940a11f5 /sysutils/udfclient
parente31c090fe26cc9a5421ac96da2e9a7b08807c627 (diff)
downloadfreebsd-ports-graphics-1df94b1eceda769149209bb358fb5efe0c7ffd7f.tar.gz
freebsd-ports-graphics-1df94b1eceda769149209bb358fb5efe0c7ffd7f.tar.zst
freebsd-ports-graphics-1df94b1eceda769149209bb358fb5efe0c7ffd7f.zip
Update to 0.4.9
PR: ports/84044 Submitted by: maintainer
Diffstat (limited to 'sysutils/udfclient')
-rw-r--r--sysutils/udfclient/Makefile3
-rw-r--r--sysutils/udfclient/distinfo4
-rw-r--r--sysutils/udfclient/files/patch-Makefile.in11
-rw-r--r--sysutils/udfclient/files/patch-udf_discop.c12
-rw-r--r--sysutils/udfclient/files/patch-udf_unix.c11
5 files changed, 25 insertions, 16 deletions
diff --git a/sysutils/udfclient/Makefile b/sysutils/udfclient/Makefile
index 21320899a1d..1e964fa8719 100644
--- a/sysutils/udfclient/Makefile
+++ b/sysutils/udfclient/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= udfclient
-PORTVERSION= 0.3.3
-PORTREVISION= 1
+PORTVERSION= 0.4.9
CATEGORIES= sysutils
MASTER_SITES= http://www.13thmonkey.org/udfclient/releases/
DISTNAME= UDFclient.${PORTVERSION}
diff --git a/sysutils/udfclient/distinfo b/sysutils/udfclient/distinfo
index 7faa6d680de..63533e16f0f 100644
--- a/sysutils/udfclient/distinfo
+++ b/sysutils/udfclient/distinfo
@@ -1,2 +1,2 @@
-MD5 (UDFclient.0.3.3.tgz) = fa87964d71148499d0bcb55c45135928
-SIZE (UDFclient.0.3.3.tgz) = 187473
+MD5 (UDFclient.0.4.9.tgz) = cd6a5160be5fd03bb580c56a7437b07f
+SIZE (UDFclient.0.4.9.tgz) = 213058
diff --git a/sysutils/udfclient/files/patch-Makefile.in b/sysutils/udfclient/files/patch-Makefile.in
new file mode 100644
index 00000000000..5b4c8b11f73
--- /dev/null
+++ b/sysutils/udfclient/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in Sun Jun 26 00:02:51 2005
++++ Makefile.in Mon Jul 25 20:34:12 2005
+@@ -33,7 +33,7 @@
+ #CFLAGS+= -D__ANONYMOUSUDF__
+
+ CFLAGS+= -fPIC -DPIC
+-POSTOBJ+= @SCSI_LIB@ @THREADLIB@ @TIMELIB@
++POSTOBJ+= @SCSI_LIB@ @THREADLIB@ #@TIMELIB@
+
+
+ # For use with the cpuflags package
diff --git a/sysutils/udfclient/files/patch-udf_discop.c b/sysutils/udfclient/files/patch-udf_discop.c
deleted file mode 100644
index ff80d4988a5..00000000000
--- a/sysutils/udfclient/files/patch-udf_discop.c
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -r udf_discop.c.orig udf_discop.c
---- udf_discop.c.orig Thu Jan 27 16:45:23 2005
-+++ udf_discop.c Fri Feb 4 22:23:50 2005
-@@ -210,7 +210,7 @@
- /* Set CD/DVD speed on 'optimal' for it doesnt seem to do it automatically */
- bzero(cmd, SCSI_CMD_LEN);
- cmd[ 0] = 0xBB; /* Set CD speed */
-- cmd[ 1] = 1; /* select CAV (1) or CLV (0) recording */
-+ cmd[ 1] = 0; /* select pure CAV (1) or CLV and non-pure CAV (0) recording */
- cmd[ 2] = 0xff;
- cmd[ 3] = 0xff; /* max read performance speed */
- cmd[ 4] = 0xff;
diff --git a/sysutils/udfclient/files/patch-udf_unix.c b/sysutils/udfclient/files/patch-udf_unix.c
new file mode 100644
index 00000000000..0103c3a6c4c
--- /dev/null
+++ b/sysutils/udfclient/files/patch-udf_unix.c
@@ -0,0 +1,11 @@
+--- udf_unix.c Sun Jun 26 00:02:48 2005
++++ udf_unix.c Mon Jul 25 11:50:58 2005
+@@ -433,7 +433,7 @@
+ if (!udf_bufcache->finish_purgethread) {
+ do {
+ /* determine the time we want to wake up again * */
+- clock_gettime(CLOCK_MONOTONIC, &wakeup);
++ clock_gettime(CLOCK_REALTIME, &wakeup);
+ wakeup.tv_sec += UDF_BUFCACHE_IDLE_SECS;
+
+ /* ask for more requests */