aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-04-12 09:03:04 +0800
committerwxs <wxs@FreeBSD.org>2009-04-12 09:03:04 +0800
commit055441b44408d0be5cf3a5a8b5678102cc7c922b (patch)
tree347d71e48a5047a4ea670af2a63d3a9e7f2a1986 /sysutils
parent25e8767e44c3a8616378880b6d981d7650a104c1 (diff)
downloadfreebsd-ports-graphics-055441b44408d0be5cf3a5a8b5678102cc7c922b.tar.gz
freebsd-ports-graphics-055441b44408d0be5cf3a5a8b5678102cc7c922b.tar.zst
freebsd-ports-graphics-055441b44408d0be5cf3a5a8b5678102cc7c922b.zip
- Update to 2.5.42-b2
PR: ports/133591 Submitted by: Dan Langille <dan@langille.org> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server-devel/Makefile68
-rw-r--r--sysutils/bacula-server-devel/distinfo6
-rw-r--r--sysutils/bacula-server-devel/files/patch-src_cats_sql.c11
-rw-r--r--sysutils/bacula-server-devel/files/patch-src_lib_jcr.c13
-rw-r--r--sysutils/bacula-server-devel/pkg-plist19
5 files changed, 94 insertions, 23 deletions
diff --git a/sysutils/bacula-server-devel/Makefile b/sysutils/bacula-server-devel/Makefile
index bdd4cab5a2f..a99ed93fd63 100644
--- a/sysutils/bacula-server-devel/Makefile
+++ b/sysutils/bacula-server-devel/Makefile
@@ -6,25 +6,29 @@
#
PORTNAME= bacula
-DISTVERSION= 2.4.4-b2
+DISTVERSION= 2.5.42-b2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
PKGNAMESUFFIX?= -server-devel
-
MAINTAINER= dan@langille.org
COMMENT?= The network backup solution (server) - DEVELOPMENT Version
CONFLICTS= bacula-server-[0-9]* bacula-client-[0-9]*
UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
+.if !defined(WITH_BAT)
+.if !defined(WITH_CLIENT_ONLY)
USE_RC_SUBR?= bacula-dir bacula-sd
+.endif
+
.if defined(WITH_CLIENT_ONLY)
SUB_FILES+= pkg-message.client
.else
SUB_FILES+= pkg-message.server
.endif
+.endif
# The user/group IDs below are registered, see
# http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/book.html#DADS-UID
@@ -33,12 +37,22 @@ BACULA_DIR?=/var/db/bacula
#
MANCOMPRESSED= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcp-wrappers=/usr/lib \
+CONFIGURE_ARGS+= --with-tcp-wrappers=/usr/lib \
--enable-smartalloc \
--with-working-dir=${BACULA_DIR} \
--with-scriptdir=${PREFIX}/share/${PORTNAME} \
+ --docdir=${DOCSDIR} \
+ --htmldir=${DOCSDIR} \
--with-readline=yes \
- --disable-conio
+ --disable-conio \
+ --enable-batch-insert \
+ --with-plugindir=${LOCALBASE}/lib \
+ --with-libdir=${PREFIX}lib/bacula \
+ --with-dump-email=root@localhost \
+ --with-job-email=root@localhost \
+ --with-db-name=bacula \
+ --with-db-user=bacula \
+ --with-baseport=9101
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --with-fd-user=root \
@@ -66,8 +80,10 @@ IS_INTERACTIVE= yes
.endif
.if defined(WITH_CLIENT_ONLY)
-OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
-OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
+OPTIONS= WXCONSOLE "Build with wxGTK based GUI console: deprecated" off
+OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console: deprecated" off
+.elif defined(WITH_BAT)
+OPTIONS=
.else
OPTIONS= SQLITE3 "Use SqLite-3 database instead of SqLite-2" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
@@ -78,7 +94,7 @@ OPTIONS+= MTX "Install mtx for control of autochanger devices" off
OPTIONS+= NLS "Native Language Support via gettext utilities" on
OPTIONS+= OPENSSL "Enable OpenSSL for encrypted communication" off
-# Prepare if gnome-console is selected this must be happen before
+# Prepare if bgnome-console is selected this must be happen before
# include of bsd.port.pre.mk!
WANT_GNOME= yes
.if defined(WITH_GNOMECONSOLE)
@@ -87,6 +103,10 @@ USE_GNOME= libgnome gnomelibs libgnomeui
PLIST_SUB+= BACULA_DIR=${BACULA_DIR}
+.if !defined(WITH_BAT)
+PLIST_SUB+= BACULA_DIR=${BACULA_DIR}
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_NLS)
@@ -103,7 +123,7 @@ CONFIGURE_ARGS+= --enable-client-only
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.client
PKGINSTALL= ${PKGDIR}/pkg-install.client
-# Build gnome-console
+# Build bgnome-console
.if defined(WITH_GNOMECONSOLE)
CONFIGURE_ARGS+= --enable-gnome
PLIST_SUB+= GNOMECONS=""
@@ -112,7 +132,7 @@ PLIST_SUB+= GNOMECONS=""
WITHOUT_GNOME= yes
PLIST_SUB+= GNOMECONS="@comment "
.endif
-# Build wx-console
+# Build bwx-console
.if defined(WITH_WXCONSOLE)
USE_WX= 2.4
CONFIGURE_ARGS+= --enable-wx-console
@@ -158,12 +178,15 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/mtx:${PORTSDIR}/misc/mtx
CONFIGURE_ARGS+= --with-openssl
.endif
+.if !defined(WITH_BAT)
.if defined(WITH_CLIENT_ONLY)
MAN8=bacula-fd.8 bconsole.8
.else
MAN8=bacula.8 bacula-dir.8 bacula-sd.8 bcopy.8 bextract.8 bls.8 bscan.8 btape.8 btraceback.8 dbcheck.8
-MAN1=bsmtp.1 bat.1
+MAN1=bsmtp.1 bacula-bgnome-console.1 bacula-tray-monitor.1 bacula-bwxconsole.1
+.endif
.endif
+
MAKE_ARGS+= -E MAN8 -E MAN1
MAKE_ENV+= MAN8="${MAN8}" MAN1="${MAN1}"
@@ -203,6 +226,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^fd_subdirs = /s|src/filed||' -e 's|src/console||' ${WRKSRC}/Makefile.in
.endif
+.if !target(pre-install)
pre-install:
if [ ! -d "${BACULA_DIR}" ]; then \
${ECHO_CMD} "creating ${BACULA_DIR}" ; \
@@ -214,7 +238,10 @@ pre-install:
# Extend /etc/services and install UID/GID
@ ${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+.endif
+
+.if !target(post-install)
post-install:
.if defined(WITH_CLIENT_ONLY)
# Extend only /etc/services
@@ -230,19 +257,19 @@ post-install:
${ECHO_CMD} "etc/bconsole.conf.sample" >> ${TMPPLIST}; \
fi
.if defined(WITH_WXCONSOLE)
- if [ -f ${PREFIX}/etc/wx-console.conf.new ]; then \
- ${ECHO_CMD} "etc/wx-console.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/wx-console.conf ];
- ${MV} ${PREFIX}/etc/wx-console.conf ${PREFIX}/etc/wx-console.conf.sample; \
- ${ECHO_CMD} "etc/wx-console.conf.sample" >> ${TMPPLIST}; \
+ if [ -f ${PREFIX}/etc/bwx-console.conf.new ]; then \
+ ${ECHO_CMD} "etc/bwx-console.conf.new" >> ${TMPPLIST}; \
+ elif [ -f ${PREFIX}/etc/bwx-console.conf ]; then \
+ ${MV} ${PREFIX}/etc/bwx-console.conf ${PREFIX}/etc/bwx-console.conf.sample; \
+ ${ECHO_CMD} "etc/bwx-console.conf.sample" >> ${TMPPLIST}; \
fi
.endif
.if defined(WITH_GNOMECONSOLE)
- if [ -f ${PREFIX}/etc/gnome-console.conf.new ]; then \
- ${ECHO_CMD} "etc/gnome-console.conf.new" >> ${TMPPLIST}; \
- elif [ -f ${PREFIX}/etc/gnome-console.conf ]; then \
- ${MV} ${PREFIX}/etc/gnome-console.conf ${PREFIX}/etc/gnome-console.conf.sample; \
- ${ECHO_CMD} "etc/gnome-console.conf.sample" >> ${TMPPLIST}; \
+ if [ -f ${PREFIX}/etc/bgnome-console.conf.new ]; then \
+ ${ECHO_CMD} "etc/bgnome-console.conf.new" >> ${TMPPLIST}; \
+ elif [ -f ${PREFIX}/etc/bgnome-console.conf ]; then \
+ ${MV} ${PREFIX}/etc/bgnome-console.conf ${PREFIX}/etc/bgnome-console.conf.sample; \
+ ${ECHO_CMD} "etc/bgnome-console.conf.sample" >> ${TMPPLIST}; \
fi
.endif
@@ -274,5 +301,6 @@ post-install:
done
@${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/bacula-server-devel/distinfo b/sysutils/bacula-server-devel/distinfo
index 79f284d3d43..6d0809d192f 100644
--- a/sysutils/bacula-server-devel/distinfo
+++ b/sysutils/bacula-server-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (bacula-2.4.4-b2.tar.gz) = 4726a2ebb9a0a28696fb822063d5f814
-SHA256 (bacula-2.4.4-b2.tar.gz) = 8857ba355ee1eaef068a84b4e279044f459ff7ef6c52824e1f5b3a32aaba781f
-SIZE (bacula-2.4.4-b2.tar.gz) = 3145178
+MD5 (bacula-2.5.42-b2.tar.gz) = b7c7b39295568ca27cd57b71008d8379
+SHA256 (bacula-2.5.42-b2.tar.gz) = 3239f2cbc1bf705567b93b40a69759254c5e615542de25acce00589239d604ff
+SIZE (bacula-2.5.42-b2.tar.gz) = 3789491
diff --git a/sysutils/bacula-server-devel/files/patch-src_cats_sql.c b/sysutils/bacula-server-devel/files/patch-src_cats_sql.c
new file mode 100644
index 00000000000..c8056b405fc
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/patch-src_cats_sql.c
@@ -0,0 +1,11 @@
+--- src/cats/sql.c.orig 2008-11-11 09:33:46.000000000 -0500
++++ src/cats/sql.c 2009-04-11 20:35:41.171024520 -0400
+@@ -759,7 +759,7 @@
+ if (mdb->lock.valid == RWLOCK_VALID) {
+ fprintf(fp, "\tRWLOCK=%p w_active=%i w_wait=%i\n", &mdb->lock, mdb->lock.w_active, mdb->lock.w_wait);
+ #ifndef HAVE_WIN32
+- fprintf(fp, "\t\tthreadid=0x%x mutex=%p\n", (int)mdb->lock.writer_id, &mdb->lock.mutex);
++ fprintf(fp, "\t\tthreadid=0x%lx mutex=%p\n", (long)mdb->lock.writer_id, &mdb->lock.mutex);
+ #endif
+ }
+ }
diff --git a/sysutils/bacula-server-devel/files/patch-src_lib_jcr.c b/sysutils/bacula-server-devel/files/patch-src_lib_jcr.c
new file mode 100644
index 00000000000..6b6d005840f
--- /dev/null
+++ b/sysutils/bacula-server-devel/files/patch-src_lib_jcr.c
@@ -0,0 +1,13 @@
+--- src/lib/jcr.c.orig 2009-03-06 15:00:47.000000000 -0500
++++ src/lib/jcr.c 2009-04-11 20:34:50.407999331 -0400
+@@ -1063,8 +1063,8 @@
+ fprintf(fp, "\tuse_count=%i\n",
+ jcr->use_count());
+ #else
+- fprintf(fp, "\tuse_count=%i threadid=0x%x\n",
+- jcr->use_count(), (int)jcr->my_thread_id);
++ fprintf(fp, "\tuse_count=%i threadid=0x%lx\n",
++ jcr->use_count(), (long)jcr->my_thread_id);
+ #endif
+ fprintf(fp, "\tJobType=%c JobLevel=%c\n",
+ jcr->get_JobType(), jcr->get_JobLevel());
diff --git a/sysutils/bacula-server-devel/pkg-plist b/sysutils/bacula-server-devel/pkg-plist
index 8ba64eccb53..4eefb0bc59a 100644
--- a/sysutils/bacula-server-devel/pkg-plist
+++ b/sysutils/bacula-server-devel/pkg-plist
@@ -1,3 +1,20 @@
+lib/bpipe-fd.so
+lib/libbac.la
+lib/libbac.so
+lib/libbac.so.1
+lib/libbaccfg.la
+lib/libbaccfg.so
+lib/libbaccfg.so.1
+lib/libbacfind.la
+lib/libbacfind.so
+lib/libbacfind.so.1
+lib/libbacpy.la
+lib/libbacpy.so
+lib/libbacpy.so.1
+lib/libbacsql.la
+lib/libbacsql.so
+lib/libbacsql.so.1
+sbin/bacula
sbin/bacula-dir
sbin/bacula-sd
sbin/bcopy
@@ -34,10 +51,12 @@ sbin/dbcheck
%%DATADIR%%/make_catalog_backup
%%DATADIR%%/make_%%DBTYPE%%_tables
%%DATADIR%%/mtx-changer
+%%DATADIR%%/mtx-changer.conf
%%DATADIR%%/query.sql
%%DATADIR%%/update_bacula_tables
%%DATADIR%%/update_%%DBTYPE%%_tables
+
@dirrm %%DATADIR%%
@unexec /usr/bin/killall bacula-sd > /dev/null 2>&1 || true
@unexec /usr/bin/killall bacula-dir > /dev/null 2>&1 || true