aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2016-07-19 07:36:42 +0800
committermandree <mandree@FreeBSD.org>2016-07-19 07:36:42 +0800
commit083dd1c3db2651e8e0b600bfd4a5a1796943f9ca (patch)
tree7c37e9caff483392999db0767d4b84a9ed2cfcc7 /sysutils
parent0e69febf29a44cafddb0e44ac49a8a5ec9b44368 (diff)
downloadfreebsd-ports-graphics-083dd1c3db2651e8e0b600bfd4a5a1796943f9ca.tar.gz
freebsd-ports-graphics-083dd1c3db2651e8e0b600bfd4a5a1796943f9ca.tar.zst
freebsd-ports-graphics-083dd1c3db2651e8e0b600bfd4a5a1796943f9ca.zip
Do not force options or Perl on slave ports.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index fd11a1fe12c..f174a28fe08 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -33,6 +33,16 @@ BUILD_DEPENDS+= gdd:sysutils/coreutils
PORTDOCS= NOTICE README RELEASE-NOTES SUBMITTING-PATCHES
+OPTIONS_DEFINE= PARALLELTESTS
+OPTIONS_SINGLE= SELFTEST
+OPTIONS_SINGLE_SELFTEST= NOTESTS SMALLTESTS ALLTESTS
+OPTIONS_DEFAULT= SMALLTESTS
+SELFTEST_DESC= Choose which set of self-tests to run
+NOTESTS_DESC= Do not run any self-tests (DISCOURAGED)
+SMALLTESTS_DESC=Run sets that fit into 500 MB disk space (DEFAULT)
+ALLTESTS_DESC= Run all self-tests
+PARALLELTESTS_DESC= Run self-tests in parallel (requires more disk space)
+
post-extract:
@${CHMOD} u+w ${WRKSRC}/po/*.po ${WRKSRC}/po/*.pot \
${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -45,23 +55,13 @@ PKGDEINSTALL= ${PKGINSTALL}
MAKE_ARGS+= V=1
.endif
-OPTIONS_DEFINE= PARALLELTESTS
-OPTIONS_SINGLE= SELFTEST
-OPTIONS_SINGLE_SELFTEST= NOTESTS SMALLTESTS ALLTESTS
-OPTIONS_DEFAULT= SMALLTESTS
-SELFTEST_DESC= Choose which set of self-tests to run
-NOTESTS_DESC= Do not run any self-tests (DISCOURAGED)
-SMALLTESTS_DESC=Run sets that fit into 500 MB disk space (DEFAULT)
-ALLTESTS_DESC= Run all self-tests
-PARALLELTESTS_DESC= Run self-tests in parallel (requires more disk space)
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext iconv:build
.endif
-.if empty(PORT_OPTIONS:MNOTESTS)
+.if empty(PORT_OPTIONS:MNOTESTS) && ${MASTERDIR} == ${.CURDIR}
USES+= perl5
USE_PERL5= build
.endif