aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-06-22 22:37:27 +0800
committerpav <pav@FreeBSD.org>2010-06-22 22:37:27 +0800
commit10498f64e68cc4e6d4d0877ae1b7ed9bd4403e8c (patch)
tree796d060cba3d8edba709cb683e5da75cd5b1eaaa /sysutils
parent3024c9fd6dc81c3c5ea2af82b1727099ac0fbc0b (diff)
downloadfreebsd-ports-graphics-10498f64e68cc4e6d4d0877ae1b7ed9bd4403e8c.tar.gz
freebsd-ports-graphics-10498f64e68cc4e6d4d0877ae1b7ed9bd4403e8c.tar.zst
freebsd-ports-graphics-10498f64e68cc4e6d4d0877ae1b7ed9bd4403e8c.zip
- Fix NOPORTDOCS, this port oddly installs configuration only with docs
Reported by: QAT Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/heartbeat/Makefile2
-rw-r--r--sysutils/heartbeat/pkg-plist18
2 files changed, 11 insertions, 9 deletions
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index cc25b9534c7..f46ec946352 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -167,6 +167,7 @@ pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+.if !defined(NOPORTDOCS)
# Install sample configuration
@if [ ! -f ${PREFIX}/etc/ha.d/authkeys ]; then \
${CP} -p ${DOCSDIR}/authkeys ${PREFIX}/etc/ha.d/authkeys ; \
@@ -183,6 +184,7 @@ post-install:
${CP} -p ${DOCSDIR}/logd.cf ${PREFIX}/etc/ha.d/logd.cf ; \
fi
${CP} -p ${DOCSDIR}/logd.cf ${PREFIX}/etc/ha.d/logd.cf.sample
+.endif
.if defined(WITH_LDIRECTORD)
@if [ ! -f ${PREFIX}/etc/ha.d/ldirectord.cf ]; then \
diff --git a/sysutils/heartbeat/pkg-plist b/sysutils/heartbeat/pkg-plist
index 01b82c64859..fc973857bb9 100644
--- a/sysutils/heartbeat/pkg-plist
+++ b/sysutils/heartbeat/pkg-plist
@@ -2,16 +2,16 @@ bin/cl_respawn
bin/cl_status
%%MGMT%%bin/hb_gui
etc/ha.d/README.config
-@unexec if cmp -s %D/etc/ha.d/authkeys.sample %D/etc/ha.d/authkeys; then rm -f %D/etc/ha.d/authkeys; fi
-etc/ha.d/authkeys.sample
-@exec if [ ! -f %D/etc/ha.d/authkeys ]; then cp -p %D/%F %B/authkeys; fi
-@unexec if cmp -s %D/etc/ha.d/ha.cf.sample %D/etc/ha.d/ha.cf; then rm -f %D/etc/ha.d/ha.cf; fi
-etc/ha.d/ha.cf.sample
-@exec if [ ! -f %D/etc/ha.d/ha.cf ]; then cp -p %D/%F %B/ha.cf; fi
+%%NOPORTDOCS%%@unexec if cmp -s %D/etc/ha.d/authkeys.sample %D/etc/ha.d/authkeys; then rm -f %D/etc/ha.d/authkeys; fi
+%%NOPORTDOCS%%etc/ha.d/authkeys.sample
+%%NOPORTDOCS%%@exec if [ ! -f %D/etc/ha.d/authkeys ]; then cp -p %D/%F %B/authkeys; fi
+%%NOPORTDOCS%%@unexec if cmp -s %D/etc/ha.d/ha.cf.sample %D/etc/ha.d/ha.cf; then rm -f %D/etc/ha.d/ha.cf; fi
+%%NOPORTDOCS%%etc/ha.d/ha.cf.sample
+%%NOPORTDOCS%%@exec if [ ! -f %D/etc/ha.d/ha.cf ]; then cp -p %D/%F %B/ha.cf; fi
etc/ha.d/harc
-@unexec if cmp -s %D/etc/ha.d/logd.cf.sample %D/etc/ha.d/logd.cf; then rm -f %D/etc/ha.d/logd.cf; fi
-etc/ha.d/logd.cf.sample
-@exec if [ ! -f %D/etc/ha.d/logd.cf ]; then cp -p %D/%F %B/logd.cf; fi
+%%NOPORTDOCS%%@unexec if cmp -s %D/etc/ha.d/logd.cf.sample %D/etc/ha.d/logd.cf; then rm -f %D/etc/ha.d/logd.cf; fi
+%%NOPORTDOCS%%etc/ha.d/logd.cf.sample
+%%NOPORTDOCS%%@exec if [ ! -f %D/etc/ha.d/logd.cf ]; then cp -p %D/%F %B/logd.cf; fi
%%LDIRECTORD%%@unexec if cmp -s %D/etc/ha.d/ldirectord.cf.sample %D/etc/ha.d/ldirectord.cf; then rm -f %D/etc/ha.d/ldirectord.cf; fi
%%LDIRECTORD%%etc/ha.d/ldirectord.cf.sample
%%LDIRECTORD%%@exec if [ ! -f %D/etc/ha.d/ldirectord.cf ]; then cp -p %D/%F %B/ldirectord.cf; fi