aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-05-04 03:46:55 +0800
committerjylefort <jylefort@FreeBSD.org>2006-05-04 03:46:55 +0800
commit26a52e59ddc4dfdddf78a6248dbbc8a00fa2ecdd (patch)
treefdd14c130d67e771c7a2a6441cf6a82c83ded844 /sysutils
parent506c162558459255da32e0c22b8cb637f145a250 (diff)
downloadfreebsd-ports-graphics-26a52e59ddc4dfdddf78a6248dbbc8a00fa2ecdd.tar.gz
freebsd-ports-graphics-26a52e59ddc4dfdddf78a6248dbbc8a00fa2ecdd.tar.zst
freebsd-ports-graphics-26a52e59ddc4dfdddf78a6248dbbc8a00fa2ecdd.zip
Call fflush() after printing sensor values. This allows to use mbmon
in scripts, etc.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mbmon/Makefile2
-rw-r--r--sysutils/mbmon/files/patch-mbmon.c14
2 files changed, 11 insertions, 5 deletions
diff --git a/sysutils/mbmon/Makefile b/sysutils/mbmon/Makefile
index e5847ff9d41..89e8a20282c 100644
--- a/sysutils/mbmon/Makefile
+++ b/sysutils/mbmon/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mbmon
PORTVERSION= 205
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/
DISTNAME= xmbmon${PORTVERSION}
diff --git a/sysutils/mbmon/files/patch-mbmon.c b/sysutils/mbmon/files/patch-mbmon.c
index 5eca1d5b8d3..dbb1be28f0e 100644
--- a/sysutils/mbmon/files/patch-mbmon.c
+++ b/sysutils/mbmon/files/patch-mbmon.c
@@ -1,7 +1,5 @@
-$FreeBSD$
-
---- mbmon.c Fri Aug 13 10:23:32 2004
-+++ mbmon.c Tue Dec 27 16:59:48 2005
+--- mbmon.c.orig Fri Aug 13 09:23:32 2004
++++ mbmon.c Wed May 3 21:32:44 2006
@@ -315,7 +315,7 @@
name = argv[0];
@@ -11,3 +9,11 @@ $FreeBSD$
#else
while ((ch = getopt(argc,argv,"VSIAfdDYe:p:c:T:F:tunNirhP:")) != -1) {
#endif
+@@ -640,6 +640,7 @@
+ else if (fanspeed == 7)
+ fprintf(out, "%4d\n%4d\n%4d\n", rot1, rot2, rot3);
+ }
++ fflush(out);
+ if (port) {
+ #ifdef LOGGING
+ if (nfd)