aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
committerflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
commit279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19 (patch)
tree2de93387d7ad1df58a7807b573d91395f20dccb9 /sysutils
parent604a42f7a6032c5db4396ed6acc540dc4fc691c4 (diff)
downloadfreebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.gz
freebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.zst
freebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.zip
readd php 5.3.13 and all its modules as php53*
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/php53-fileinfo/Makefile14
-rw-r--r--sysutils/php53-fileinfo/files/patch-config.m421
-rw-r--r--sysutils/php53-posix/Makefile14
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c25689a4003..38f9fc54fc4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -674,6 +674,8 @@
SUBDIR += php5-fileinfo
SUBDIR += php5-posix
SUBDIR += php52-posix
+ SUBDIR += php53-fileinfo
+ SUBDIR += php53-posix
SUBDIR += pidof
SUBDIR += pipemeter
SUBDIR += plasma-applet-apcups
diff --git a/sysutils/php53-fileinfo/Makefile b/sysutils/php53-fileinfo/Makefile
new file mode 100644
index 00000000000..1196563c515
--- /dev/null
+++ b/sysutils/php53-fileinfo/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-fileinfo
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -fileinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php53-fileinfo/files/patch-config.m4 b/sysutils/php53-fileinfo/files/patch-config.m4
new file mode 100644
index 00000000000..1348023ccf6
--- /dev/null
+++ b/sysutils/php53-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+
diff --git a/sysutils/php53-posix/Makefile b/sysutils/php53-posix/Makefile
new file mode 100644
index 00000000000..5c4c83eb95d
--- /dev/null
+++ b/sysutils/php53-posix/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-posix
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -posix
+
+.include "${MASTERDIR}/Makefile"