aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-05-17 21:17:37 +0800
committerflo <flo@FreeBSD.org>2012-05-17 21:17:37 +0800
commit299da8516c77b0e63aa1209e0e147b1a9c1b9675 (patch)
tree20bdb373d3b0d98391fac79b1b4ce42cfae765e7 /sysutils
parent49c434e843e584f7f79e2f02449b382dd620413e (diff)
downloadfreebsd-ports-graphics-299da8516c77b0e63aa1209e0e147b1a9c1b9675.tar.gz
freebsd-ports-graphics-299da8516c77b0e63aa1209e0e147b1a9c1b9675.tar.zst
freebsd-ports-graphics-299da8516c77b0e63aa1209e0e147b1a9c1b9675.zip
- Add a few more patches i missed in the original commit.
- Bump PORTREVISION accordingly
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/php53-posix/Makefile2
-rw-r--r--sysutils/php53-posix/files/patch-posix.c38
2 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/php53-posix/Makefile b/sysutils/php53-posix/Makefile
index 5c4c83eb95d..754a7027307 100644
--- a/sysutils/php53-posix/Makefile
+++ b/sysutils/php53-posix/Makefile
@@ -5,6 +5,8 @@
# $FreeBSD$
#
+PORTREVISION= 1
+
CATEGORIES= sysutils
MASTERDIR= ${.CURDIR}/../../lang/php53
diff --git a/sysutils/php53-posix/files/patch-posix.c b/sysutils/php53-posix/files/patch-posix.c
new file mode 100644
index 00000000000..d2365b24956
--- /dev/null
+++ b/sysutils/php53-posix/files/patch-posix.c
@@ -0,0 +1,38 @@
+--- posix.c.orig Fri Feb 23 00:40:39 2007
++++ posix.c Sun May 13 17:52:27 2007
+@@ -838,7 +838,7 @@
+ #if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
+ buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ g = &gbuf;
+@@ -888,7 +888,7 @@
+
+ grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
+ if (grbuflen < 1) {
+- RETURN_FALSE;
++ grbuflen = 1024;
+ }
+
+ grbuf = emalloc(grbuflen);
+@@ -955,7 +955,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
+ buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (buflen < 1) {
+- RETURN_FALSE;
++ buflen = 1024;
+ }
+ buf = emalloc(buflen);
+ pw = &pwbuf;
+@@ -1004,7 +1004,7 @@
+ #if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
+ pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
+ if (pwbuflen < 1) {
+- RETURN_FALSE;
++ pwbuflen = 1024;
+ }
+ pwbuf = emalloc(pwbuflen);
+