aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-03 20:03:25 +0800
committersat <sat@FreeBSD.org>2007-04-03 20:03:25 +0800
commit33862d3cce2ee32529b811d2d9338c6904a97ef0 (patch)
tree32f53228fee8fc3e77dc8ede29936aabb70429f6 /sysutils
parent9b612aea2edb3b2ac30a8304bb3265b60a14a0e9 (diff)
downloadfreebsd-ports-graphics-33862d3cce2ee32529b811d2d9338c6904a97ef0.tar.gz
freebsd-ports-graphics-33862d3cce2ee32529b811d2d9338c6904a97ef0.tar.zst
freebsd-ports-graphics-33862d3cce2ee32529b811d2d9338c6904a97ef0.zip
Add port sysutils/ts:
task spooler is a Unix batch system where the tasks spooled run one after the other. Each user in each system has his own job queue. The tasks are run in the correct context (that of enqueue) from any shell/process, and its output/results can be easily watched. It is very useful when you know that your commands depend on a lot of RAM, a lot of disk use, give a lot of output, or for whatever reason it's better not to run them at the same time. WWW: http://vicerveza.homeunix.net/~viric/soft/ts/ Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ts/Makefile31
-rw-r--r--sysutils/ts/distinfo3
-rw-r--r--sysutils/ts/files/patch-execute.c26
-rw-r--r--sysutils/ts/pkg-descr10
5 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c9692ff1862..abc9d4ae918 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -613,6 +613,7 @@
SUBDIR += toshctl
SUBDIR += tracker
SUBDIR += tree
+ SUBDIR += ts
SUBDIR += tss
SUBDIR += ttyload
SUBDIR += tua
diff --git a/sysutils/ts/Makefile b/sysutils/ts/Makefile
new file mode 100644
index 00000000000..ea0987ee86b
--- /dev/null
+++ b/sysutils/ts/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ts
+# Date created: 3 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ts
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= http://vicerveza.homeunix.net/~viric/soft/ts/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Serial task spooler
+
+WRKSRC= ${WRKDIR}/ts
+ALL_TARGET= ts
+PLIST_BIN= bin/${PORTNAME}
+PORTDOCS= OBJECTIVES PROTOCOL README TODO TRICKS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$^|$${.ALLSRC}|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/ts/distinfo b/sysutils/ts/distinfo
new file mode 100644
index 00000000000..0eb95069c5c
--- /dev/null
+++ b/sysutils/ts/distinfo
@@ -0,0 +1,3 @@
+MD5 (ts-0.3.tar.gz) = fc7d79bf36ed06ff2046aecfcfd9de0b
+SHA256 (ts-0.3.tar.gz) = 852b0a9cbacddd7ac0ed7ba7c1f3d7a44b6eb8775d59256ba88c42e8bd20006d
+SIZE (ts-0.3.tar.gz) = 31545
diff --git a/sysutils/ts/files/patch-execute.c b/sysutils/ts/files/patch-execute.c
new file mode 100644
index 00000000000..29920e42734
--- /dev/null
+++ b/sysutils/ts/files/patch-execute.c
@@ -0,0 +1,26 @@
+--- ./execute.c.orig Tue Apr 3 15:07:38 2007
++++ ./execute.c Tue Apr 3 15:07:48 2007
+@@ -16,7 +16,6 @@
+ #include "msg.h"
+ #include "main.h"
+
+-static void program_signal();
+
+ /* Returns errorlevel */
+ static int run_parent(int fd_read_filename, int pid)
+@@ -204,15 +203,3 @@
+ {
+ }
+
+-static void program_signal()
+-{
+- struct sigaction act;
+-
+- act.sa_handler = sigchld_handler;
+- /* Reset the mask */
+- memset(&act.sa_mask,0,sizeof(act.sa_mask));
+- act.sa_flags = SA_NOCLDSTOP;
+- act.sa_restorer = NULL;
+-
+- sigaction(SIGCHLD, &act, NULL);
+-}
diff --git a/sysutils/ts/pkg-descr b/sysutils/ts/pkg-descr
new file mode 100644
index 00000000000..862345918b3
--- /dev/null
+++ b/sysutils/ts/pkg-descr
@@ -0,0 +1,10 @@
+task spooler is a Unix batch system where the tasks spooled run one
+after the other. Each user in each system has his own job queue. The
+tasks are run in the correct context (that of enqueue) from any
+shell/process, and its output/results can be easily watched. It is
+very useful when you know that your commands depend on a lot of RAM,
+a lot of disk use, give a lot of output, or for whatever reason it's
+better not to run them at the same time.
+
+WWW: http://vicerveza.homeunix.net/~viric/soft/ts/
+Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>