aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-01 20:33:11 +0800
committermiwi <miwi@FreeBSD.org>2009-07-01 20:33:11 +0800
commit7737f8ef4da4f6dc7235968d614cebb4716e1781 (patch)
tree11fc3d2dd0b8bd344f109b5b531efb2f3b5c6893 /sysutils
parent3550687d237ad8970f00705034ae5f1d007d7e50 (diff)
downloadfreebsd-ports-graphics-7737f8ef4da4f6dc7235968d614cebb4716e1781.tar.gz
freebsd-ports-graphics-7737f8ef4da4f6dc7235968d614cebb4716e1781.tar.zst
freebsd-ports-graphics-7737f8ef4da4f6dc7235968d614cebb4716e1781.zip
- Fix core dump on AMD64
- Pass maintainership to submitter PR: 135866 Submitted by: "J.R. Oldroyd" <fbsd@opal.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-cpugraph-plugin/Makefile4
-rw-r--r--sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.c20
-rw-r--r--sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.h19
3 files changed, 41 insertions, 2 deletions
diff --git a/sysutils/xfce4-cpugraph-plugin/Makefile b/sysutils/xfce4-cpugraph-plugin/Makefile
index d2718572313..11e3b728fb5 100644
--- a/sysutils/xfce4-cpugraph-plugin/Makefile
+++ b/sysutils/xfce4-cpugraph-plugin/Makefile
@@ -7,12 +7,12 @@
PORTNAME= xfce4-cpugraph-plugin
PORTVERSION= 0.3.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils xfce
MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fbsd@opal.com
COMMENT= XFce4 systemload plugin with multiple CPU display modes
GNU_CONFIGURE= yes
diff --git a/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.c b/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.c
new file mode 100644
index 00000000000..727fc0dec94
--- /dev/null
+++ b/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.c
@@ -0,0 +1,20 @@
+--- panel-plugin/cpu.c.orig 2005-10-09 05:06:46.000000000 -0400
++++ panel-plugin/cpu.c 2009-06-15 18:29:08.000000000 -0400
+@@ -606,7 +606,7 @@
+ op->m_Notebook = gtk_notebook_new ();
+ gtk_container_set_border_width (GTK_CONTAINER (op->m_Notebook),
+ BORDER - 2);
+- label = gtk_label_new (_("Apperance"));
++ label = gtk_label_new (_("Appearance"));
+ gtk_notebook_append_page (GTK_NOTEBOOK (op->m_Notebook),
+ GTK_WIDGET (vbox2), GTK_WIDGET (label));
+ label = gtk_label_new (_("Advanced"));
+@@ -952,7 +952,7 @@
+ SetHistorySize (CPUGraph * base, int size)
+ {
+ base->m_History =
+- (long *) realloc (base->m_History, size * sizeof (long));
++ (int *) realloc (base->m_History, size * sizeof (int));
+ int i;
+
+ for (i = size - 1; i >= base->m_Values; i--)
diff --git a/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.h b/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.h
new file mode 100644
index 00000000000..b8b0f0bddc4
--- /dev/null
+++ b/sysutils/xfce4-cpugraph-plugin/files/patch-panel-plugin-cpu.h
@@ -0,0 +1,19 @@
+--- panel-plugin/cpu.h.orig 2005-10-09 05:19:34.000000000 -0400
++++ panel-plugin/cpu.h 2009-06-15 18:07:25.000000000 -0400
+@@ -10,6 +10,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include <libxfce4util/libxfce4util.h>
+ #include <libxfcegui4/libxfcegui4.h>
+@@ -83,7 +84,7 @@
+
+ guint m_TimeoutID; // Timeout ID for the tooltip;
+ long m_CPUUsage;
+- long *m_History;
++ int *m_History;
+ int m_Values;
+
+ int m_Orientation;