aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-03-12 13:24:52 +0800
committermiwi <miwi@FreeBSD.org>2014-03-12 13:24:52 +0800
commit79f5e0fd6b4393b137da99bc4090d3fb07b0fb04 (patch)
tree036ea38ab99580a8841ebab3b2f8bcf08aad7130 /sysutils
parent72ca379cd3458be48a6167d8fc0883050f3b3271 (diff)
downloadfreebsd-ports-graphics-79f5e0fd6b4393b137da99bc4090d3fb07b0fb04.tar.gz
freebsd-ports-graphics-79f5e0fd6b4393b137da99bc4090d3fb07b0fb04.tar.zst
freebsd-ports-graphics-79f5e0fd6b4393b137da99bc4090d3fb07b0fb04.zip
- Stage support
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/consolekit/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/consolekit/Makefile b/sysutils/consolekit/Makefile
index ba70942b387..3d887721fb2 100644
--- a/sysutils/consolekit/Makefile
+++ b/sysutils/consolekit/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
WRKSRC= ${WRKDIR}/ConsoleKit-${PORTVERSION}
USE_BZIP2= yes
USE_XORG= x11
-USES= pathfix gettext pkgconfig
-USE_GMAKE= yes
+USES= pathfix gettext pkgconfig gmake
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -25,13 +24,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-pid-file=/var/run/${PORTNAME}.pid \
--localstatedir=/var
-NO_STAGE= yes
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/ck-get-x11-display-device \
- ${PREFIX}/libexec/ck-get-x11-display-device
+ ${STAGEDIR}${PREFIX}/libexec/ck-get-x11-display-device
${INSTALL_SCRIPT} ${FILESDIR}/ck-get-x11-server-pid \
- ${PREFIX}/libexec/ck-get-x11-server-pid
- ${MKDIR} /var/log/ConsoleKit
- ${TOUCH} /var/log/ConsoleKit/history
+ ${STAGEDIR}${PREFIX}/libexec/ck-get-x11-server-pid
+ ${MKDIR} ${STAGEDIR}/var/log/ConsoleKit
+ ${TOUCH} ${STAGEDIR}/var/log/ConsoleKit/history
.include <bsd.port.mk>