aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarck <marck@FreeBSD.org>2012-04-19 04:55:35 +0800
committermarck <marck@FreeBSD.org>2012-04-19 04:55:35 +0800
commit8deb3b2fd0f191fd3181455cbc9b9b85f7caf0b8 (patch)
tree41c3cda4391efcb9ce0d5b839d98ae3a1b3029a5 /sysutils
parent87366d1df332d507ae5fa26d831ace706e38e2c2 (diff)
downloadfreebsd-ports-graphics-8deb3b2fd0f191fd3181455cbc9b9b85f7caf0b8.tar.gz
freebsd-ports-graphics-8deb3b2fd0f191fd3181455cbc9b9b85f7caf0b8.tar.zst
freebsd-ports-graphics-8deb3b2fd0f191fd3181455cbc9b9b85f7caf0b8.zip
Add a knob for serial console speed, and make 9600 the default.
Requested by: kib
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/memtest86+/Makefile11
-rw-r--r--sysutils/memtest86+/files/extra-patch-config.h3
-rw-r--r--sysutils/memtest86+/files/extra-patch-config.h-11520020
3 files changed, 29 insertions, 5 deletions
diff --git a/sysutils/memtest86+/Makefile b/sysutils/memtest86+/Makefile
index 5016824da44..30fce8bf72b 100644
--- a/sysutils/memtest86+/Makefile
+++ b/sysutils/memtest86+/Makefile
@@ -7,7 +7,7 @@
PORTNAME= memtest86+
PORTVERSION= 4.20
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.memtest.org/download/${PORTVERSION}/
@@ -26,7 +26,8 @@ BOOT_DIR?= /boot/opt
OPTIONS= ISO "Build bootable ISO image" off \
BOOT "Build ELF image loadable by boot2 and loader" on \
- SERIAL "Enable serial console at COM1/115200" off
+ SERIAL "Enable serial console at COM1/9600" off \
+ HISPEED "Set COM1 serial console speed to 115200" off
.include <bsd.port.pre.mk>
@@ -45,8 +46,12 @@ ALL_TARGET+= iso
.endif
.if defined(WITH_SERIAL)
-EXTRA_PATCHES+= ${PATCHDIR}//extra-patch-config.h
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-config.h
+
+.if defined(WITH_HISPEED)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-config.h-115200
.endif
+.endif # WITH_SERIAL
.if ${OSVERSION} < 700042
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile
diff --git a/sysutils/memtest86+/files/extra-patch-config.h b/sysutils/memtest86+/files/extra-patch-config.h
index 9033f592759..aadccec9de4 100644
--- a/sysutils/memtest86+/files/extra-patch-config.h
+++ b/sysutils/memtest86+/files/extra-patch-config.h
@@ -14,8 +14,7 @@ $FreeBSD$
#define SERIAL_TTY 0
/* SERIAL_BAUD_RATE - Baud rate for the serial console */
--#define SERIAL_BAUD_RATE 9600
-+#define SERIAL_BAUD_RATE 115200
+ #define SERIAL_BAUD_RATE 9600
/* BEEP_MODE - Beep on error. Default off, Change to 1 to enable */
#define BEEP_MODE 0
diff --git a/sysutils/memtest86+/files/extra-patch-config.h-115200 b/sysutils/memtest86+/files/extra-patch-config.h-115200
new file mode 100644
index 00000000000..9ed71911b42
--- /dev/null
+++ b/sysutils/memtest86+/files/extra-patch-config.h-115200
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- config.h.orig
++++ config.h
+@@ -13,13 +13,13 @@
+ /* SERIAL_CONSOLE_DEFAULT - The default state of the serial console. */
+ /* This is normally off since it slows down testing. Change to a 1 */
+ /* to enable. */
+ #define SERIAL_CONSOLE_DEFAULT 1
+
+ /* SERIAL_TTY - The default serial port to use. 0=ttyS0, 1=ttyS1 */
+ #define SERIAL_TTY 0
+
+ /* SERIAL_BAUD_RATE - Baud rate for the serial console */
+-#define SERIAL_BAUD_RATE 9600
++#define SERIAL_BAUD_RATE 115200
+
+ /* BEEP_MODE - Beep on error. Default off, Change to 1 to enable */
+ #define BEEP_MODE 0