aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-04-17 14:17:33 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-04-17 14:17:33 +0800
commit9597ac3975b9778af2dbd7128de8825ccd2f2f1b (patch)
tree1dfbe6bafc95536dcdfa1dfbd240cf54cd12aad1 /sysutils
parentf47313104a3c3e1ebc06d6a4f52592a1a2310dbd (diff)
downloadfreebsd-ports-graphics-9597ac3975b9778af2dbd7128de8825ccd2f2f1b.tar.gz
freebsd-ports-graphics-9597ac3975b9778af2dbd7128de8825ccd2f2f1b.tar.zst
freebsd-ports-graphics-9597ac3975b9778af2dbd7128de8825ccd2f2f1b.zip
- Stage
- Add missing run-time dependency on bglibs ====>> Checking shared library dependencies /lib/libc.so.7 /usr/local/lib/bglibs/libbg-sysdeps.so.2 /usr/local/lib/bglibs/libbg.so.2
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ucspi-proxy/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/ucspi-proxy/Makefile b/sysutils/ucspi-proxy/Makefile
index cd8148f6292..9e650f92097 100644
--- a/sysutils/ucspi-proxy/Makefile
+++ b/sysutils/ucspi-proxy/Makefile
@@ -9,22 +9,21 @@ MASTER_SITES= http://untroubled.org/ucspi-proxy/
MAINTAINER= dale.woolridge@gmail.com
COMMENT= A proxy program for UCSPI servers and clients
-BUILD_DEPENDS= ${BGLIBS_LIB}/libbg-unix.a:${PORTSDIR}/devel/bglibs
+LIB_DEPENDS= libbg.so:${PORTSDIR}/devel/bglibs
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
BGLIBS_INCLUDE= ${LOCALBASE}/include/bglibs
-MAN1= ucspi-proxy-http-xlate.1 ucspi-proxy.1
-
PLIST_FILES= bin/ucspi-proxy bin/ucspi-proxy-log bin/ucspi-proxy-pop3 \
- bin/ucspi-proxy-imap bin/ucspi-proxy-http-xlate
+ bin/ucspi-proxy-imap bin/ucspi-proxy-http-xlate \
+ man/man1/ucspi-proxy-http-xlate.1.gz \
+ man/man1/ucspi-proxy.1.gz
-NO_STAGE= yes
do-configure:
- ${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-bin
- ${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
+ ${ECHO_CMD} "${STAGEDIR}${PREFIX}/bin" > ${WRKSRC}/conf-bin
+ ${ECHO_CMD} "${STAGEDIR}${MANPREFIX}/man" > ${WRKSRC}/conf-man
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
${ECHO_CMD} "${BGLIBS_INCLUDE}" > ${WRKSRC}/conf-bgincs