aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-06-26 01:22:05 +0800
committerahze <ahze@FreeBSD.org>2005-06-26 01:22:05 +0800
commit9c12fd30500f26c40be8dc0afeb8851edebff2df (patch)
tree797873909edc81123a775d0aeb73d987982d6615 /sysutils
parentf23e581f3ef2fe8a1fe4840356f1cf241b025a81 (diff)
downloadfreebsd-ports-graphics-9c12fd30500f26c40be8dc0afeb8851edebff2df.tar.gz
freebsd-ports-graphics-9c12fd30500f26c40be8dc0afeb8851edebff2df.tar.zst
freebsd-ports-graphics-9c12fd30500f26c40be8dc0afeb8851edebff2df.zip
- Add support for muine audio player plugin
* allows you to write your playlist directly from Muine.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/serpentine/Makefile24
-rw-r--r--sysutils/serpentine/pkg-descr1
-rw-r--r--sysutils/serpentine/pkg-plist2
3 files changed, 26 insertions, 1 deletions
diff --git a/sysutils/serpentine/Makefile b/sysutils/serpentine/Makefile
index 4cd4a0acad1..ce43279b2bb 100644
--- a/sysutils/serpentine/Makefile
+++ b/sysutils/serpentine/Makefile
@@ -26,4 +26,26 @@ USE_GMAKE= yes
USE_GSTREAMER= core
USE_PYTHON= 2.4+
-.include <bsd.port.mk>
+OPTIONS= MUINE "Cd-Burner Plugin for muine audio player" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MUINE) || exists(${X11BASE}/bin/muine)
+BUILD_DEPENDS+= muine:${PORTSDIR}/audio/muine
+RUN_DEPENDS+= muine:${PORTSDIR}/audio/muine
+PLIST_SUB+= MUINE=""
+.else
+PLIST_SUB+= MUINE="@comment "
+.endif
+
+.if defined(WITH_MUINE) || exists(${X11BASE}/bin/muine)
+post-build:
+ cd ${WRKSRC}/muine-plugin && ${GMAKE}
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/muine/plugins
+ ${INSTALL_DATA} ${WRKSRC}/muine-plugin/SerpentinePlugin.dll \
+ ${PREFIX}/lib/muine/plugins
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/serpentine/pkg-descr b/sysutils/serpentine/pkg-descr
index 7a0aae59709..22350b40414 100644
--- a/sysutils/serpentine/pkg-descr
+++ b/sysutils/serpentine/pkg-descr
@@ -9,5 +9,6 @@ usability and compability. Its features are:
o Supports drag and drop: drop musics directly from Rhythmbox or Nautilus!
o Clean and easy to use interface
o Easy integration with other applications
+ o Muine plugin: allows you to write your playlist directly from Muine.
WWW: http://s1x.homelinux.net/projects/serpentine
diff --git a/sysutils/serpentine/pkg-plist b/sysutils/serpentine/pkg-plist
index 50b2069305b..6de5fc9bc02 100644
--- a/sysutils/serpentine/pkg-plist
+++ b/sysutils/serpentine/pkg-plist
@@ -1,4 +1,5 @@
bin/serpentine
+%%MUINE%%lib/muine/plugins/SerpentinePlugin.dll
%%PYTHON_SITELIBDIR%%/serpentine/__init__.py
%%PYTHON_SITELIBDIR%%/serpentine/__init__.pyc
%%PYTHON_SITELIBDIR%%/serpentine/__init__.pyo
@@ -74,5 +75,6 @@ share/applications/serpentine.desktop
@unexec rmdir %D/share/applications 2> /dev/null || true
@dirrm %%PYTHON_SITELIBDIR%%/serpentine/plugins
@dirrm %%PYTHON_SITELIBDIR%%/serpentine
+%%MUINE%%@unexec rmdir %D/lib/muine/plugins 2> /dev/null || true
@unexec rmdir %D/%%PYTHON_SITELIBDIR%% 2> /dev/null || true
@unexec rmdir %D/%%PYTHON_LIBDIR%% 2> /dev/null || true