aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-04-13 02:46:59 +0800
committerknu <knu@FreeBSD.org>2002-04-13 02:46:59 +0800
commit9dfbc1cc6b655bd1bc750a9579c527adb6800c1e (patch)
treeb52d2e9d178e01d3f958209e87e0f0b8dd7f4070 /sysutils
parentab81bfea49b3d931e3fe085d916b0aef6ca90f50 (diff)
downloadfreebsd-ports-graphics-9dfbc1cc6b655bd1bc750a9579c527adb6800c1e.tar.gz
freebsd-ports-graphics-9dfbc1cc6b655bd1bc750a9579c527adb6800c1e.tar.zst
freebsd-ports-graphics-9dfbc1cc6b655bd1bc750a9579c527adb6800c1e.zip
Add ruby-devel-logger 1.0.0, a lightweight logging library for Ruby.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ruby-devel-logger/Makefile37
-rw-r--r--sysutils/ruby-devel-logger/distinfo1
-rw-r--r--sysutils/ruby-devel-logger/pkg-comment1
-rw-r--r--sysutils/ruby-devel-logger/pkg-descr4
-rw-r--r--sysutils/ruby-devel-logger/pkg-plist12
6 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 125fb4f101f..a94553caf5d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -149,6 +149,7 @@
SUBDIR += rotate
SUBDIR += rtty
SUBDIR += ruby-application.rb
+ SUBDIR += ruby-devel-logger
SUBDIR += ruby-log4r
SUBDIR += ruby-quota
SUBDIR += safecat
diff --git a/sysutils/ruby-devel-logger/Makefile b/sysutils/ruby-devel-logger/Makefile
new file mode 100644
index 00000000000..9666d205165
--- /dev/null
+++ b/sysutils/ruby-devel-logger/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby/Devel::Logger
+# Date created: 13 April 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= devel-logger
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/Devel__Logger/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+EXAMPLES= sample/*
+DOCS= README
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} ./install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/ruby-devel-logger/distinfo b/sysutils/ruby-devel-logger/distinfo
new file mode 100644
index 00000000000..19b14da0162
--- /dev/null
+++ b/sysutils/ruby-devel-logger/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/devel-logger-1_0_0.tar.gz) = 5802e22178ee68473c8303a4d953cae2
diff --git a/sysutils/ruby-devel-logger/pkg-comment b/sysutils/ruby-devel-logger/pkg-comment
new file mode 100644
index 00000000000..21525d0a51b
--- /dev/null
+++ b/sysutils/ruby-devel-logger/pkg-comment
@@ -0,0 +1 @@
+A lightweight logging library for Ruby
diff --git a/sysutils/ruby-devel-logger/pkg-descr b/sysutils/ruby-devel-logger/pkg-descr
new file mode 100644
index 00000000000..4bb28b5166e
--- /dev/null
+++ b/sysutils/ruby-devel-logger/pkg-descr
@@ -0,0 +1,4 @@
+This is Devel::Logger, a lightweight logging library for Ruby.
+
+WWW: http://rrr.jin.gr.jp/doc/Devel__Logger/
+Author: NaHi (NAKAMURA, Hiroshi) <nahi@keynauts.com>
diff --git a/sysutils/ruby-devel-logger/pkg-plist b/sysutils/ruby-devel-logger/pkg-plist
new file mode 100644
index 00000000000..baf615ba0e6
--- /dev/null
+++ b/sysutils/ruby-devel-logger/pkg-plist
@@ -0,0 +1,12 @@
+%%RUBY_SITELIBDIR%%/application.rb
+%%RUBY_SITELIBDIR%%/devel/logger.rb
+@dirrm %%RUBY_SITELIBDIR%%/devel
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/devel-logger/app.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/devel-logger/log.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/devel-logger/logShifting.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/devel-logger/logToFile.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/devel-logger/logs/.keep_me
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/devel-logger/logs
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/devel-logger
+%%PORTDOCS%%%%RUBY_DOCDIR%%/devel-logger/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/devel-logger