aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-04-18 04:20:01 +0800
committercy <cy@FreeBSD.org>2012-04-18 04:20:01 +0800
commita7ba2059225a4be4281701e515a047c8b5bb8f8f (patch)
tree132eb86fd585c9388c3abfac7d001867f603f7d7 /sysutils
parent9837d6fd45fea9f9ad26cbc01c6c02de63ef9cbc (diff)
downloadfreebsd-ports-graphics-a7ba2059225a4be4281701e515a047c8b5bb8f8f.tar.gz
freebsd-ports-graphics-a7ba2059225a4be4281701e515a047c8b5bb8f8f.tar.zst
freebsd-ports-graphics-a7ba2059225a4be4281701e515a047c8b5bb8f8f.zip
Wecome to libumberlog.
The libumberlog library serves two purposes: it's either a drop-in replacement for the syslog() system call, in which case it turns the default syslog messages into CEE-enhanced messages, with a CEE-JSON payload, and some automatically discovered fields. Or, it can be used as a stand-alone library, that provides a syslog()-like API, with the ability to add arbitrary key-value pairs to the resulting JSON payload. WWW: http://algernon.github.com/libumberlog/ Submitted by: Peter Czanik <czanik@balabit.hu>, our syslog-ng upline
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/libumberlog/Makefile23
-rw-r--r--sysutils/libumberlog/distinfo2
-rw-r--r--sysutils/libumberlog/pkg-descr8
-rw-r--r--sysutils/libumberlog/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8d4c049558a..466bbdf659f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -449,6 +449,7 @@
SUBDIR += libpcbsd
SUBDIR += libretto-config
SUBDIR += libsunacl
+ SUBDIR += libumberlog
SUBDIR += libutempter
SUBDIR += lineak-defaultplugin
SUBDIR += lineak-kdeplugins
diff --git a/sysutils/libumberlog/Makefile b/sysutils/libumberlog/Makefile
new file mode 100644
index 00000000000..79d6f4a8cf5
--- /dev/null
+++ b/sysutils/libumberlog/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libumberlog
+# Date created: 12 April 2012
+# Whom: czanik@balabit.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= libumberlog
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils
+MASTER_SITES= http://cloud.github.com/downloads/algernon/libumberlog/
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= CEE-enhanced syslog API
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= yes
+
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
+.include <bsd.port.mk>
diff --git a/sysutils/libumberlog/distinfo b/sysutils/libumberlog/distinfo
new file mode 100644
index 00000000000..eacfa2b33ec
--- /dev/null
+++ b/sysutils/libumberlog/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libumberlog-0.2.0.tar.gz) = c4f4bf77f28d630f8cb9cc359e1293ebe66e781c204bf4c9f38368599443426f
+SIZE (libumberlog-0.2.0.tar.gz) = 516425
diff --git a/sysutils/libumberlog/pkg-descr b/sysutils/libumberlog/pkg-descr
new file mode 100644
index 00000000000..7a8cddf6c37
--- /dev/null
+++ b/sysutils/libumberlog/pkg-descr
@@ -0,0 +1,8 @@
+The libumberlog library serves two purposes: it's either a drop-in
+replacement for the syslog() system call, in which case it turns the default
+syslog messages into CEE-enhanced messages, with a CEE-JSON payload, and
+some automatically discovered fields. Or, it can be used as a stand-alone
+library, that provides a syslog()-like API, with the ability to add
+arbitrary key-value pairs to the resulting JSON payload.
+
+WWW: http://algernon.github.com/libumberlog/
diff --git a/sysutils/libumberlog/pkg-plist b/sysutils/libumberlog/pkg-plist
new file mode 100644
index 00000000000..1632fddad62
--- /dev/null
+++ b/sysutils/libumberlog/pkg-plist
@@ -0,0 +1,6 @@
+include/umberlog.h
+lib/libumberlog.a
+lib/libumberlog.la
+lib/libumberlog.so
+lib/libumberlog.so.1
+libdata/pkgconfig/libumberlog.pc