aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2001-02-06 10:43:53 +0800
committerjeh <jeh@FreeBSD.org>2001-02-06 10:43:53 +0800
commitb60d3c6d38b241c4ef9baa676233d16a305849a7 (patch)
tree2acb4c5b253a16510b133be108f1fdc27127274c /sysutils
parent5dc20202f400010fbef7a601e297a59363a592dc (diff)
downloadfreebsd-ports-graphics-b60d3c6d38b241c4ef9baa676233d16a305849a7.tar.gz
freebsd-ports-graphics-b60d3c6d38b241c4ef9baa676233d16a305849a7.tar.zst
freebsd-ports-graphics-b60d3c6d38b241c4ef9baa676233d16a305849a7.zip
Fix a divide by zero.
Bump PORTREVISION PR: 24884 Submitted by: Barney Wolff <barney@databus.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/healthd/Makefile1
-rw-r--r--sysutils/healthd/files/patch-aa11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/healthd/Makefile b/sysutils/healthd/Makefile
index 1a38cdad073..a880c88fd84 100644
--- a/sysutils/healthd/Makefile
+++ b/sysutils/healthd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= healthd
PORTVERSION= 0.6.4
+PORTREVISION= 1
CATEGORIES= sysutils ipv6
MASTER_SITES= http://healthd.thehousleys.net/
diff --git a/sysutils/healthd/files/patch-aa b/sysutils/healthd/files/patch-aa
new file mode 100644
index 00000000000..5ceb9504adc
--- /dev/null
+++ b/sysutils/healthd/files/patch-aa
@@ -0,0 +1,11 @@
+--- getMBinfo.c.orig Sun Jan 7 11:24:43 2001
++++ getMBinfo.c Mon Feb 5 21:41:37 2001
+@@ -293,7 +293,7 @@
+ else
+ *r2 = 1350000 / (n * div2 * FanType2);
+ n=ReadByte(0x2A);
+- if (n == 255)
++ if ((n == 255) || (n==0))
+ *r3 = 0;
+ else
+ *r3 = 1350000 / (n * div3 * FanType3);