aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-12-04 17:19:46 +0800
committercrees <crees@FreeBSD.org>2011-12-04 17:19:46 +0800
commitb99b67899c7a1457100c97b7c7e47aabf03ac3e7 (patch)
tree71171c7ca8e90fd3fb841d8ea0185fec2fabde75 /sysutils
parent845c8e36afdcbafb75853d5c1e1c9339068bc1ea (diff)
downloadfreebsd-ports-graphics-b99b67899c7a1457100c97b7c7e47aabf03ac3e7.tar.gz
freebsd-ports-graphics-b99b67899c7a1457100c97b7c7e47aabf03ac3e7.tar.zst
freebsd-ports-graphics-b99b67899c7a1457100c97b7c7e47aabf03ac3e7.zip
Fix distfile detection logic to use IGNORE instead; more standard
Approved by: maintainer implicit (gerrit.beine@gmx.de; fix timed out previous commit) Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/megarc/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/sysutils/megarc/Makefile b/sysutils/megarc/Makefile
index 1395f81dca4..8477ee2c904 100644
--- a/sysutils/megarc/Makefile
+++ b/sysutils/megarc/Makefile
@@ -25,23 +25,10 @@ RESTRICTED= Must be downloaded directly from the manufacturer
PLIST_FILES= sbin/megarc
PORTDOCS= *
-MANUAL_PACKAGE_BUILD= distfile unavailable
+.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-DISTFILE_INSTRUCTIONS=\n\
-The distribution file is not freely avaliable.\n\
-The binary is shipped on the Megaraid Universal Software Suite\n\
-CD which accompanies any boxed LSI Logic RAID storage adaptor.\n\
-\n\
-Copy ${DISTNAME}${EXTRACT_SUFX} to ${DISTDIR} and try again.\n\
-\n\
-For further instructions, see http://www.freebsdwiki.net/index.php/Megarc\n\n
-.endif
-
-pre-fetch:
-.if defined(DISTFILE_INSTRUCTIONS)
- @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
- @exit 1
+IGNORE= has a distribution file that is not freely avaliable. The binary is shipped on the Megaraid Universal Software Suite CD which accompanies any boxed LSI Logic RAID storage adaptor. Copy ${DISTNAME}${EXTRACT_SUFX} to ${DISTDIR} and try again. For further instructions, see http://www.freebsdwiki.net/index.php/Megarc
.endif
post-extract:
@@ -54,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Release\ History.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>