aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2010-08-03 03:45:30 +0800
committerbapt <bapt@FreeBSD.org>2010-08-03 03:45:30 +0800
commitbcf3dfef7c5a213b07d9441a6e73bfea355c55c1 (patch)
tree8b6c73d90dd5178478de8b95492291f40dea612c /sysutils
parent331a839cf645e2cc5c4a80aee110f14b4ac67191 (diff)
downloadfreebsd-ports-graphics-bcf3dfef7c5a213b07d9441a6e73bfea355c55c1.tar.gz
freebsd-ports-graphics-bcf3dfef7c5a213b07d9441a6e73bfea355c55c1.tar.zst
freebsd-ports-graphics-bcf3dfef7c5a213b07d9441a6e73bfea355c55c1.zip
DT PS Tree shows running processes as a tree. It is a reimplementation
of pstree from PSmisc for FreeBSD. It also works without /proc and will show the full set of processes in a jail even if init is not present. WWW: http://code.douglasthrift.net/trac/dtpstree PR: ports/149108 Submitted by: Douglas Thrift Approved by: jadawin@ (co-mentor)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dtpstree/Makefile26
-rw-r--r--sysutils/dtpstree/distinfo3
-rw-r--r--sysutils/dtpstree/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4ffe601bb8f..f9c7312d48e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -173,6 +173,7 @@
SUBDIR += downtime
SUBDIR += dt
SUBDIR += dtc
+ SUBDIR += dtpstree
SUBDIR += du2ps
SUBDIR += duff
SUBDIR += dump9660
diff --git a/sysutils/dtpstree/Makefile b/sysutils/dtpstree/Makefile
new file mode 100644
index 00000000000..7d00d953376
--- /dev/null
+++ b/sysutils/dtpstree/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dtpstree
+# Date created: 17 June 2010
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtpstree
+PORTVERSION= 1.0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://apt.douglasthrift.net/files/${PORTNAME}/ \
+ http://code.douglasthrift.net/files/${PORTNAME}/
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Display a tree of processes
+
+LICENSE= ASL
+
+USE_XZ= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKEFILE= GNUmakefile
+MAN1= dtpstree.1
+PLIST_FILES= bin/dtpstree
+
+.include <bsd.port.mk>
diff --git a/sysutils/dtpstree/distinfo b/sysutils/dtpstree/distinfo
new file mode 100644
index 00000000000..ed2c2f77b5b
--- /dev/null
+++ b/sysutils/dtpstree/distinfo
@@ -0,0 +1,3 @@
+MD5 (dtpstree-1.0.2.tar.xz) = df3242cddd53e74f474381dd3648761e
+SHA256 (dtpstree-1.0.2.tar.xz) = 63804fd3549938cd27c3bdf2aafeea2b177992c50e5a4c2d8bc5f07c876c9623
+SIZE (dtpstree-1.0.2.tar.xz) = 47748
diff --git a/sysutils/dtpstree/pkg-descr b/sysutils/dtpstree/pkg-descr
new file mode 100644
index 00000000000..6021f12bd45
--- /dev/null
+++ b/sysutils/dtpstree/pkg-descr
@@ -0,0 +1,5 @@
+DT PS Tree shows running processes as a tree. It is a reimplementation
+of pstree from PSmisc for FreeBSD. It also works without /proc and will
+show the full set of processes in a jail even if init is not present.
+
+WWW: http://code.douglasthrift.net/trac/dtpstree