aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2010-10-12 09:17:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2010-10-12 09:17:40 +0800
commitbf9eb34f48c4e9efba054b56ec115a725f44fe02 (patch)
tree11e2a6364adc04690a6223ab265bfbfb4406eeeb /sysutils
parent4907013940d5e7c69e999cb3e880ecea6a57cc67 (diff)
downloadfreebsd-ports-graphics-bf9eb34f48c4e9efba054b56ec115a725f44fe02.tar.gz
freebsd-ports-graphics-bf9eb34f48c4e9efba054b56ec115a725f44fe02.tar.zst
freebsd-ports-graphics-bf9eb34f48c4e9efba054b56ec115a725f44fe02.zip
- Update to 0.6.10
PR: ports/150728 Submitted by: Jase Thew <freebsd@beardz.net> Approved by: Peter Schuller <peter.schuller@infidyne.com> (maintainer), pgollucci (mentor, implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/duplicity-devel/Makefile3
-rw-r--r--sysutils/duplicity-devel/distinfo6
-rw-r--r--sysutils/duplicity-devel/files/patch-r665-bug613448.diff136
3 files changed, 4 insertions, 141 deletions
diff --git a/sysutils/duplicity-devel/Makefile b/sysutils/duplicity-devel/Makefile
index a1d9ff0260f..97781017afe 100644
--- a/sysutils/duplicity-devel/Makefile
+++ b/sysutils/duplicity-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= duplicity
-PORTVERSION= 0.6.09
-PORTREVISION= 1
+PORTVERSION= 0.6.10
CATEGORIES= sysutils
MASTER_SITES= http://launchpad.net/duplicity/0.6-series/${PORTVERSION}/+download/
PKGNAMESUFFIX= -devel
diff --git a/sysutils/duplicity-devel/distinfo b/sysutils/duplicity-devel/distinfo
index 0ec66a2dc77..d5f47ecae25 100644
--- a/sysutils/duplicity-devel/distinfo
+++ b/sysutils/duplicity-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (duplicity-0.6.09.tar.gz) = 2ed04ce2fdfce0f47faea0c9ef95fde8
-SHA256 (duplicity-0.6.09.tar.gz) = 33718ec23db71aaf56ca8f01f1be1382bebc0ef25a155f2e12c7258cb3b33b1c
-SIZE (duplicity-0.6.09.tar.gz) = 290510
+MD5 (duplicity-0.6.10.tar.gz) = 8878d3b63fcba1b7233e11c5829b969c
+SHA256 (duplicity-0.6.10.tar.gz) = 5c7d38e58f866705e293bbf06aef973e32f196b0fa4f633433a0ae72d8b23284
+SIZE (duplicity-0.6.10.tar.gz) = 291633
diff --git a/sysutils/duplicity-devel/files/patch-r665-bug613448.diff b/sysutils/duplicity-devel/files/patch-r665-bug613448.diff
deleted file mode 100644
index 1db0d2a52ff..00000000000
--- a/sysutils/duplicity-devel/files/patch-r665-bug613448.diff
+++ /dev/null
@@ -1,136 +0,0 @@
-=== modified file 'duplicity/backend.py'
---- src/backend.py 2010-05-23 15:52:45 +0000
-+++ src/backend.py 2010-08-09 18:56:03 +0000
-@@ -372,78 +372,76 @@
- else:
- return commandline
-
-- """
-- DEPRECATED:
-- run_command(_persist) - legacy wrappers for subprocess_popen(_persist)
-- """
- def run_command(self, commandline):
-- return self.subprocess_popen(commandline)
-+ """
-+ Execute the given command line, interpreted as a shell
-+ command, with logging and error detection. If execution fails,
-+ raise a BackendException.
-+ """
-+ private = self.munge_password(commandline)
-+ log.Info(_("Running '%s'") % private)
-+ if os.system(commandline):
-+ raise BackendException("Error running '%s'" % private)
-+
- def run_command_persist(self, commandline):
-- return self.subprocess_popen_persist(commandline)
-+ """
-+ Like run_command(), but repeat the attempt several times (with
-+ a delay in between) if it fails.
-+ """
-+ private = self.munge_password(commandline)
-+ for n in range(1, globals.num_retries+1):
-+ if n > 1:
-+ # sleep before retry
-+ time.sleep(30)
-+ log.Info(gettext.ngettext("Running '%s' (attempt #%d)",
-+ "Running '%s' (attempt #%d)", n) %
-+ (private, n))
-+ if not os.system(commandline):
-+ return
-+ log.Warn(gettext.ngettext("Running '%s' failed (attempt #%d)",
-+ "Running '%s' failed (attempt #%d)", n) %
-+ (private, n), 1)
-+ log.Warn(gettext.ngettext("Giving up trying to execute '%s' after %d attempt",
-+ "Giving up trying to execute '%s' after %d attempts",
-+ globals.num_retries) % (private, globals.num_retries))
-+ raise BackendException("Error running '%s'" % private)
-
-- """
-- DEPRECATED:
-- popen(_persist) - legacy wrappers for subprocess_popen(_persist)
-- """
- def popen(self, commandline):
-- result, stdout, stderr = self.subprocess_popen(commandline)
-- return stdout
-+ """
-+ Like run_command(), but capture stdout and return it (the
-+ contents read from stdout) as a string.
-+ """
-+ private = self.munge_password(commandline)
-+ log.Info(_("Reading results of '%s'") % private)
-+ fout = os.popen(commandline)
-+ results = fout.read()
-+ if fout.close():
-+ raise BackendException("Error running '%s'" % private)
-+ return results
-+
- def popen_persist(self, commandline):
-- result, stdout, stderr = self.subprocess_popen_persist(commandline)
-- return stdout
--
-- def _subprocess_popen(self, commandline):
-- """
-- For internal use.
-- Execute the given command line, interpreted as a shell command.
-- Returns int Exitcode, string StdOut, string StdErr
-- """
-- from subprocess import Popen, PIPE
-- p = Popen(commandline, shell=True, stdout=PIPE, stderr=PIPE)
-- stdout, stderr = p.communicate()
--
-- return p.returncode, stdout, stderr
--
-- def subprocess_popen(self, commandline):
-- """
-- Execute the given command line with error check.
-- Returns int Exitcode, string StdOut, string StdErr
--
-- Raise a BackendException on failure.
-- """
-- private = self.munge_password(commandline)
-- log.Info(_("Reading results of '%s'") % private)
-- result, stdout, stderr = self._subprocess_popen(commandline)
-- if result != 0:
-- raise BackendException("Error running '%s'" % private)
-- return result, stdout, stderr
--
-- def subprocess_popen_persist(self, commandline):
-- """
-- Execute the given command line with error check.
-- Retries globals.num_retries times with 30s delay.
-- Returns int Exitcode, string StdOut, string StdErr
--
-- Raise a BackendException on failure.
-+ """
-+ Like run_command_persist(), but capture stdout and return it
-+ (the contents read from stdout) as a string.
- """
- private = self.munge_password(commandline)
- for n in range(1, globals.num_retries+1):
-- # sleep before retry
- if n > 1:
-+ # sleep before retry
- time.sleep(30)
- log.Info(_("Reading results of '%s'") % private)
-- result, stdout, stderr = self._subprocess_popen(commandline)
-- if result == 0:
-- return result, stdout, stderr
-- elif result == 1280 and self.parsed_url.scheme == 'ftp':
-+ fout = os.popen(commandline)
-+ results = fout.read()
-+ result_status = fout.close()
-+ if not result_status:
-+ return results
-+ elif result_status == 1280 and self.parsed_url.scheme == 'ftp':
- # This squelches the "file not found" result fromm ncftpls when
- # the ftp backend looks for a collection that does not exist.
- return ''
- log.Warn(gettext.ngettext("Running '%s' failed (attempt #%d)",
- "Running '%s' failed (attempt #%d)", n) %
- (private, n))
-- if stdout or stderr:
-- log.Warn(_("Error is:\n%s") % stderr + (stderr and stdout and "\n") + stdout)
- log.Warn(gettext.ngettext("Giving up trying to execute '%s' after %d attempt",
- "Giving up trying to execute '%s' after %d attempts",
- globals.num_retries) % (private, globals.num_retries))
-