aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-30 07:29:33 +0800
committerswills <swills@FreeBSD.org>2014-03-30 07:29:33 +0800
commitd41989892aa160c9734385ca1b26f823309e55c2 (patch)
treea5f0ebaa7667671cbc38985eaffca43737b7e39b /sysutils
parent1f4116f47df230a5c6413cdfb66345b47c5b756e (diff)
downloadfreebsd-ports-graphics-d41989892aa160c9734385ca1b26f823309e55c2.tar.gz
freebsd-ports-graphics-d41989892aa160c9734385ca1b26f823309e55c2.tar.zst
freebsd-ports-graphics-d41989892aa160c9734385ca1b26f823309e55c2.zip
This agent manages the puppet agent, unlike the older puppetd plugin this one
supports Puppet 3 and recent changes made to its locking and status files. WWW: https://github.com/puppetlabs/mcollective-puppet-agent/ PR: ports/186532 Submitted by: Anes Mukhametov <anes@anes.su>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mcollective-puppet-agent/Makefile27
-rw-r--r--sysutils/mcollective-puppet-agent/distinfo2
-rw-r--r--sysutils/mcollective-puppet-agent/pkg-descr4
-rw-r--r--sysutils/mcollective-puppet-agent/pkg-plist83
5 files changed, 117 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index edf4b7983b9..30343dd89dd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -499,6 +499,7 @@
SUBDIR += mcelog
SUBDIR += mcollective
SUBDIR += mcollective-nrpe-agent
+ SUBDIR += mcollective-puppet-agent
SUBDIR += mcron
SUBDIR += mcweject
SUBDIR += mdcp
diff --git a/sysutils/mcollective-puppet-agent/Makefile b/sysutils/mcollective-puppet-agent/Makefile
new file mode 100644
index 00000000000..9d17cf35de2
--- /dev/null
+++ b/sysutils/mcollective-puppet-agent/Makefile
@@ -0,0 +1,27 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= mcollective-puppet-agent
+PORTVERSION= 1.7.0
+CATEGORIES= sysutils
+
+MAINTAINER= anes@anes.su
+COMMENT= Puppet agent manager for mcollective
+
+RUN_DEPENDS= mcollective>=2:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${PORTVERSION}
+GH_COMMIT= 6e565cb
+
+NO_BUILD= yes
+
+MCOLLECTIVEDIR= ${STAGEDIR}${PREFIX}/share/mcollective
+
+do-install:
+ @${MKDIR} ${MCOLLECTIVEDIR}
+ @cd ${WRKSRC} && ${PAX} -r -w . ${MCOLLECTIVEDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-puppet-agent/distinfo b/sysutils/mcollective-puppet-agent/distinfo
new file mode 100644
index 00000000000..e7ffcbcc7db
--- /dev/null
+++ b/sysutils/mcollective-puppet-agent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcollective-puppet-agent-1.7.0.tar.gz) = c7695bf8cfeea6cbf4f81591c01906776f9a88748fc87ce7af1cebf744107dae
+SIZE (mcollective-puppet-agent-1.7.0.tar.gz) = 38033
diff --git a/sysutils/mcollective-puppet-agent/pkg-descr b/sysutils/mcollective-puppet-agent/pkg-descr
new file mode 100644
index 00000000000..848de0b8c2b
--- /dev/null
+++ b/sysutils/mcollective-puppet-agent/pkg-descr
@@ -0,0 +1,4 @@
+This agent manages the puppet agent, unlike the older puppetd plugin this one
+supports Puppet 3 and recent changes made to its locking and status files.
+
+WWW: https://github.com/puppetlabs/mcollective-puppet-agent/
diff --git a/sysutils/mcollective-puppet-agent/pkg-plist b/sysutils/mcollective-puppet-agent/pkg-plist
new file mode 100644
index 00000000000..21962947f7c
--- /dev/null
+++ b/sysutils/mcollective-puppet-agent/pkg-plist
@@ -0,0 +1,83 @@
+share/mcollective/.gitignore
+share/mcollective/.rspec
+share/mcollective/.travis.yml
+share/mcollective/CHANGELOG.md
+share/mcollective/Gemfile
+share/mcollective/README.md
+share/mcollective/Rakefile
+share/mcollective/agent/puppet.ddl
+share/mcollective/agent/puppet.rb
+share/mcollective/aggregate/boolean_summary.ddl
+share/mcollective/aggregate/boolean_summary.rb
+share/mcollective/application/puppet.rb
+share/mcollective/data/puppet_data.ddl
+share/mcollective/data/puppet_data.rb
+share/mcollective/data/resource_data.ddl
+share/mcollective/data/resource_data.rb
+share/mcollective/ext/build_defaults.yaml
+share/mcollective/ext/packaging.rake
+share/mcollective/ext/project_data.yaml
+share/mcollective/ext/debian/changelog.erb
+share/mcollective/ext/debian/compat
+share/mcollective/ext/debian/control
+share/mcollective/ext/debian/copyright
+share/mcollective/ext/debian/mcollective-puppet-agent.install
+share/mcollective/ext/debian/mcollective-puppet-client.install
+share/mcollective/ext/debian/mcollective-puppet-common.install
+share/mcollective/ext/debian/rules
+share/mcollective/ext/redhat/mcollective-puppet.spec.erb
+share/mcollective/spec/spec_helper.rb
+share/mcollective/spec/agent/puppet_agent_spec.rb
+share/mcollective/spec/aggregate/boolean_summary_spec.rb
+share/mcollective/spec/application/puppet_spec.rb
+share/mcollective/spec/data/puppet_data_spec.rb
+share/mcollective/spec/data/resource_data_spec.rb
+share/mcollective/spec/fixtures/last_run_report.yaml
+share/mcollective/spec/fixtures/last_run_summary.yaml
+share/mcollective/spec/util/puppet_agent_mgr_spec.rb
+share/mcollective/spec/util/puppetrunner_spec.rb
+share/mcollective/spec/util/puppet_agent_mgr/common_spec.rb
+share/mcollective/spec/util/v2/manager_spec.rb
+share/mcollective/spec/util/v2/unix_spec.rb
+share/mcollective/spec/util/v3/manager_spec.rb
+share/mcollective/spec/util/v3/unix_spec.rb
+share/mcollective/spec/util/v3/windows_spec.rb
+share/mcollective/spec/validator/puppet_resource_validator_spec.rb
+share/mcollective/spec/validator/puppet_server_address_validator_spec.rb
+share/mcollective/spec/validator/puppet_tags_validator_spec.rb
+share/mcollective/spec/validator/puppet_variable_validator_spec.rb
+share/mcollective/util/puppet_agent_mgr.rb
+share/mcollective/util/puppetrunner.rb
+share/mcollective/util/puppet_agent_mgr/common.rb
+share/mcollective/util/puppet_agent_mgr/v2/manager.rb
+share/mcollective/util/puppet_agent_mgr/v2/unix.rb
+share/mcollective/util/puppet_agent_mgr/v2/windows.rb
+share/mcollective/util/puppet_agent_mgr/v3/manager.rb
+share/mcollective/util/puppet_agent_mgr/v3/unix.rb
+share/mcollective/util/puppet_agent_mgr/v3/windows.rb
+share/mcollective/validator/puppet_resource_validator.ddl
+share/mcollective/validator/puppet_resource_validator.rb
+share/mcollective/validator/puppet_server_address_validator.ddl
+share/mcollective/validator/puppet_server_address_validator.rb
+share/mcollective/validator/puppet_tags_validator.ddl
+share/mcollective/validator/puppet_tags_validator.rb
+share/mcollective/validator/puppet_variable_validator.ddl
+share/mcollective/validator/puppet_variable_validator.rb
+@dirrm share/mcollective/util/puppet_agent_mgr/v3
+@dirrm share/mcollective/util/puppet_agent_mgr/v2
+@dirrm share/mcollective/util/puppet_agent_mgr
+@dirrm share/mcollective/util
+@dirrm share/mcollective/spec/validator
+@dirrm share/mcollective/spec/util/v3
+@dirrm share/mcollective/spec/util/v2
+@dirrm share/mcollective/spec/util/puppet_agent_mgr
+@dirrm share/mcollective/spec/util
+@dirrm share/mcollective/spec/fixtures
+@dirrm share/mcollective/spec/data
+@dirrm share/mcollective/spec/application
+@dirrm share/mcollective/spec/aggregate
+@dirrm share/mcollective/spec/agent
+@dirrm share/mcollective/spec
+@dirrm share/mcollective/ext/redhat
+@dirrm share/mcollective/ext/debian
+@dirrm share/mcollective/ext