aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-05-27 17:14:07 +0800
committerak <ak@FreeBSD.org>2012-05-27 17:14:07 +0800
commitdff5aded9fbf61d85361b3fb1248a17bf22e115e (patch)
tree1fcab0e20b51df27a1fd77f03eea883e7a47cfe3 /sysutils
parent2f3dd7ad4eec482f0ab32591d54a440e23fb0ee2 (diff)
downloadfreebsd-ports-graphics-dff5aded9fbf61d85361b3fb1248a17bf22e115e.tar.gz
freebsd-ports-graphics-dff5aded9fbf61d85361b3fb1248a17bf22e115e.tar.zst
freebsd-ports-graphics-dff5aded9fbf61d85361b3fb1248a17bf22e115e.zip
- Unbreak after yacc update in r235723
PR: ports/168311 Submitted by: Jan Beich <jbeich@tormail.org> Approved by: eadler, itetcu (mentors, implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/uhidd/Makefile2
-rw-r--r--sysutils/uhidd/files/extra-patch-uhidd-parser.y17
2 files changed, 19 insertions, 0 deletions
diff --git a/sysutils/uhidd/Makefile b/sysutils/uhidd/Makefile
index 2d0f8ab4169..134d716cf67 100644
--- a/sysutils/uhidd/Makefile
+++ b/sysutils/uhidd/Makefile
@@ -40,6 +40,8 @@ MAKE_ENV+= DEBUG_FLAGS='${DEBUG_FLAGS}'
.if ${OSVERSION} < 800069
IGNORE= does not build with the old USB stack
+.elif ${OSVERSION} > 1000012
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-uhidd-parser.y
.endif
.if !(exists(${SYSDIR}/Makefile) || exists(${SRC_BASE}/sys/Makefile))
diff --git a/sysutils/uhidd/files/extra-patch-uhidd-parser.y b/sysutils/uhidd/files/extra-patch-uhidd-parser.y
new file mode 100644
index 00000000000..e9d0c71f0d1
--- /dev/null
+++ b/sysutils/uhidd/files/extra-patch-uhidd-parser.y
@@ -0,0 +1,17 @@
+--- uhidd/parser.y~
++++ uhidd/parser.y
+@@ -32,13 +32,13 @@
+ #include <err.h>
+ #include <errno.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <syslog.h>
+
+ #include "uhidd.h"
+
+ extern int yylex(void);
+-extern int yyparse(void);
+ extern int lineno;
+ extern FILE *yyin;
+