aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-07-02 16:01:52 +0800
committermiwi <miwi@FreeBSD.org>2011-07-02 16:01:52 +0800
commite10a891fc85260f5fc39f4f00f4b1af705d4e899 (patch)
tree3f639798b5e7a05db38ccef57ea8d9e0425c3a2a /sysutils
parent6fd4a08add456611b34b96e823879f8c40ac25f3 (diff)
downloadfreebsd-ports-graphics-e10a891fc85260f5fc39f4f00f4b1af705d4e899.tar.gz
freebsd-ports-graphics-e10a891fc85260f5fc39f4f00f4b1af705d4e899.tar.zst
freebsd-ports-graphics-e10a891fc85260f5fc39f4f00f4b1af705d4e899.zip
Atop is an ASCII full-screen performance monitor that is capable of reporting
the activity of all processes (even if processes have finished during the interval), daily logging of system and process activity for long-term analysis, highlighting overloaded system resources by using colors, etc. At regular intervals, it shows system-level activity related to the CPU, memory, swap, disks, and network layers, and for every active process it shows the CPU utilization, the memory growth, priority, username, state, and exit code. WWW: http://openfacts2.berlios.de/wikien/index.php/BerliosProject:Atop-freebsd PR: ports/158536 Submitted by: Alex Samorukov <samm at os2.kiev.ua>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/atop/Makefile42
-rw-r--r--sysutils/atop/distinfo2
-rw-r--r--sysutils/atop/files/atop.in44
-rw-r--r--sysutils/atop/pkg-descr9
-rw-r--r--sysutils/atop/pkg-plist7
6 files changed, 105 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 90f6a60a896..0009d150291 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -42,6 +42,7 @@
SUBDIR += asusoled
SUBDIR += ataidle
SUBDIR += atitvout
+ SUBDIR += atop
SUBDIR += automounter
SUBDIR += autopsy
SUBDIR += avfs
diff --git a/sysutils/atop/Makefile b/sysutils/atop/Makefile
new file mode 100644
index 00000000000..c09493183d1
--- /dev/null
+++ b/sysutils/atop/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: atop
+# Date created: 2011-06-30
+# Whom: Alex Samorukov <samm@os2.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atop
+PORTVERSION= 1.26.b3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR=atop-freebsd
+DISTNAME= ${PORTNAME}-${PORTVERSION:C|b|fbsd.beta|}
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= ASCII Monitor for system resources and process activity
+
+LICENSE= GPLv2
+USE_BZIP2= yes
+MAKEFILE= Makefile.fbsd
+MAN1= atop.1 atopsar.1
+MAN5= atoprc.5
+LOGDIR?= /var/log/atop
+
+USE_RC_SUBR= atop
+PLIST_SUB+= LOGDIR="${LOGDIR}"
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/atop ${PREFIX}/bin
+ @${LN} -sf ${PREFIX}/bin/atop ${PREFIX}/bin/atopsar
+.for manpage in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/man/${manpage} ${MAN1PREFIX}/man/man1/
+.endfor
+ @${INSTALL_MAN} ${WRKSRC}/man/${MAN5} ${MAN5PREFIX}/man/man5/
+ @${MKDIR} ${LOGDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/AUTHOR ${WRKSRC}/ChangeLog \
+ ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/atop/distinfo b/sysutils/atop/distinfo
new file mode 100644
index 00000000000..1910f8f4798
--- /dev/null
+++ b/sysutils/atop/distinfo
@@ -0,0 +1,2 @@
+SHA256 (atop-1.26.fbsd.beta3.tar.bz2) = 5c06ee28cc215a88ccec25555253d5d732d7ce5fb43b8c2931f37283fc40f1c8
+SIZE (atop-1.26.fbsd.beta3.tar.bz2) = 130202
diff --git a/sysutils/atop/files/atop.in b/sysutils/atop/files/atop.in
new file mode 100644
index 00000000000..f628ba3474b
--- /dev/null
+++ b/sysutils/atop/files/atop.in
@@ -0,0 +1,44 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: atop
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: shutdown
+
+# Define these atop_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/atop
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+#
+atop_enable="${atop_enable-NO}"
+atop_pidfile="/var/run/atop.pid"
+
+. /etc/rc.subr
+
+name="atop"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/atop"
+start_cmd="atop_start"
+
+atop_start()
+{
+ if [ -z "$rc_fast" -a -n "$rc_pid" ]; then
+ echo 1>&2 "${name} already running? (pid=$rc_pid)."
+ return 1
+ fi
+ check_startmsgs && echo "Starting ${name}."
+ /usr/sbin/daemon -p $pidfile ${command} -w /var/log/atop/atop_`date '+%Y%m%d'` ${atop_flags} ${atop_interval}
+ _run_rc_postcmd
+}
+
+load_rc_config $name
+
+: ${atop_interval=10}
+: ${atop_flags=""}
+
+pidfile="${atop_pidfile}"
+
+run_rc_command "$1"
diff --git a/sysutils/atop/pkg-descr b/sysutils/atop/pkg-descr
new file mode 100644
index 00000000000..23e9efefe44
--- /dev/null
+++ b/sysutils/atop/pkg-descr
@@ -0,0 +1,9 @@
+Atop is an ASCII full-screen performance monitor that is capable of reporting
+the activity of all processes (even if processes have finished during the
+interval), daily logging of system and process activity for long-term analysis,
+highlighting overloaded system resources by using colors, etc.
+At regular intervals, it shows system-level activity related to the CPU, memory,
+swap, disks, and network layers, and for every active process it shows the CPU
+utilization, the memory growth, priority, username, state, and exit code.
+
+WWW: http://openfacts2.berlios.de/wikien/index.php/BerliosProject:Atop-freebsd
diff --git a/sysutils/atop/pkg-plist b/sysutils/atop/pkg-plist
new file mode 100644
index 00000000000..1575ef6e2b6
--- /dev/null
+++ b/sysutils/atop/pkg-plist
@@ -0,0 +1,7 @@
+bin/atop
+bin/atopsar
+%%PORTDOCS%%%%DOCSDIR%%/AUTHOR
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %%LOGDIR%% 2> /dev/null || true