aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2016-08-03 19:13:30 +0800
committercpm <cpm@FreeBSD.org>2016-08-03 19:13:30 +0800
commitf12d86aa2e82c1e1e6ce39f4d7ae260e5b729cf9 (patch)
treef3ccf1121f2454293e87aa6a5d8d40f5d260b25f /sysutils
parent278dfe8cf0f03d8bb5e111b14316da4d08af28ef (diff)
downloadfreebsd-ports-graphics-f12d86aa2e82c1e1e6ce39f4d7ae260e5b729cf9.tar.gz
freebsd-ports-graphics-f12d86aa2e82c1e1e6ce39f4d7ae260e5b729cf9.tar.zst
freebsd-ports-graphics-f12d86aa2e82c1e1e6ce39f4d7ae260e5b729cf9.zip
- Fix build on FreeBSD 11.0/i386 and HEAD.
- Mark BROKEN on 9.3 - We have no MASTER_SITES and no DISTFILES. Therefore these are empty. PR: 211321 Submitted by: Tobias Kortkamp (maintainer) Reviewed by: junovitch (mentor) Approved by: junovitch (mentor) MFH: 2016Q3 (ports-secteam build fix blanket)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/showbeastie/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index d19b7b14217..90c1ec2b93c 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -4,8 +4,8 @@
PORTNAME= showbeastie
PORTVERSION= 0.2
CATEGORIES= sysutils
-MASTER_SITES=
-DISTFILES=
+MASTER_SITES= # none
+DISTFILES= # none
MAINTAINER= t@tobik.me
COMMENT= Preview FreeBSD loader logos
@@ -25,6 +25,8 @@ PLIST_FILES= bin/${PORTNAME}
# Make sure building succeeds on HEAD
MAKE_ARGS+= -m ${SRC_BASE}/share/mk
+BROKEN_FreeBSD_9= builds but expects newer loader environment
+
pre-patch:
@${MKDIR} ${WRKSRC}
@${TAR} -C ${SRC_BASE}/sys/boot/ficl \
@@ -35,6 +37,10 @@ post-patch:
${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_BASE}/sys/boot/common|g' \
${WRKSRC}/Makefile
+# Make sure building on FreeBSD 11.0/i386 works. Calls to biospci_* are not
+# needed for this program.
+ ${REINPLACE_CMD} 's|ifdef __i386__|if 0|g' ${WRKSRC}/loader.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/testmain ${STAGEDIR}${PREFIX}/bin/${PORTNAME}