aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-10-30 11:10:09 +0800
committeralepulver <alepulver@FreeBSD.org>2007-10-30 11:10:09 +0800
commitf143c1109ded80c4bbce26cb507a06351b6b50e3 (patch)
tree6c7bf1795e8ad936e342fdba76d38ee50579476a /sysutils
parent7a36256e809975d0fc5016368d079fb24fc00147 (diff)
downloadfreebsd-ports-graphics-f143c1109ded80c4bbce26cb507a06351b6b50e3.tar.gz
freebsd-ports-graphics-f143c1109ded80c4bbce26cb507a06351b6b50e3.tar.zst
freebsd-ports-graphics-f143c1109ded80c4bbce26cb507a06351b6b50e3.zip
- Bump PORTREVISION.
- Create pkg-message from SUB_FILES instead of using ${SED} to print. - Add a note in pkg-message and clean up. - Create a symlink of ${PREFIX}/sbin/mount_fusefs to /usr/sbin to allow mounting from /etc/fstab. - Add "BEFORE: mountlate" to rc.d script. This has been verified to work with sysutils/fusefs-ntfs (see changes to pkg-message in last commit). PR: ports/117516 Submitted by: alepulver (myself) Approved by: Anish Mistry <amistry@am-productions.biz> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-kmod/Makefile12
-rw-r--r--sysutils/fusefs-kmod/files/fusefs.in1
-rw-r--r--sysutils/fusefs-kmod/files/pkg-message.in15
-rw-r--r--sysutils/fusefs-kmod/pkg-message8
-rw-r--r--sysutils/fusefs-kmod/pkg-plist2
5 files changed, 26 insertions, 12 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index ae16095e510..52907cdf768 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1
+PORTREVISION= 1
CATEGORIES= sysutils kld
MASTER_SITES= http://fuse4bsd.creo.hu/downloads/ \
http://am-productions.biz/docs/
@@ -65,6 +66,10 @@ IGNORE= requires the Kernel source to be installed. Set SRC_BASE if it is not i
IGNORE= requires the userland sources to be installed. Set SRC_BASE if it is not in /usr/src
.endif
+.if !defined(WITH_AUTOSETUP)
+SUB_FILES= pkg-message
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/deplate.rb/deplate/g' \
${WRKSRC}/doc/Makefile
@@ -81,15 +86,14 @@ pre-install:
@${MKDIR} ${KMODDIR}
post-install:
-.if (defined(WITH_AUTOSETUP) && !defined(BATCH) && !defined(PACKAGE_BUILDING)) \
- || (defined(WITH_AUTOSETUP) && defined(BATCH) && !defined(PACKAGE_BUILDING))
+ @${LN} -s ${PREFIX}/sbin/mount_fusefs /usr/sbin
+.if defined(WITH_AUTOSETUP) && !defined(PACKAGE_BUILDING)
@${SED} -e 's|@@PREFIX@@|${PREFIX}|g' \
${FILESDIR}/${SETUP} > ${WRKDIR}/${SETUP}
@${ECHO} "Modifying global startup config files and loading module...";
${SH} ${WRKDIR}/${SETUP}
.else
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
- -e "s|%%MODULE_PATH%%|${MODULE_PATH}|g" ${PKGMESSAGE}
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.endif
.if !defined(NOPORTDOCS)
diff --git a/sysutils/fusefs-kmod/files/fusefs.in b/sysutils/fusefs-kmod/files/fusefs.in
index bcbbe9f4741..c6eb33661ca 100644
--- a/sysutils/fusefs-kmod/files/fusefs.in
+++ b/sysutils/fusefs-kmod/files/fusefs.in
@@ -4,6 +4,7 @@
#
# PROVIDE: fusefs
# REQUIRE: sysctl
+# BEFORE: mountlate
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
diff --git a/sysutils/fusefs-kmod/files/pkg-message.in b/sysutils/fusefs-kmod/files/pkg-message.in
new file mode 100644
index 00000000000..3b7c8d73c7e
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/pkg-message.in
@@ -0,0 +1,15 @@
+==============================================================================
+
+In order to automatically load the fuse module on startup, you need to:
+
+ - Add fusefs_enable="YES" to your /etc/rc.conf.
+ - Run "%%PREFIX%%/etc/rc.d/fusefs start" (for the first time).
+
+Set "sysctl vfs.usermount=1" if you want to be able to mount fuse devices as
+an ordinary user.
+
+Now fuse filesystems (sysutils/fusefs-*) can be mounted at startup from
+/etc/fstab with the "late" parameter. This requires a symlink in /usr/sbin
+named "mount_<fstype>", which is not created by all the fusefs ports.
+
+==============================================================================
diff --git a/sysutils/fusefs-kmod/pkg-message b/sysutils/fusefs-kmod/pkg-message
deleted file mode 100644
index 0152b694caa..00000000000
--- a/sysutils/fusefs-kmod/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-In order to automatically load the fuse module on startup, you need to
-set the following settings:
-
- - Add fusefs_enable="YES" to your /etc/rc.conf
-
-%%PREFIX%%/etc/rc.d/fusefs start will load the module for the first time
-after the installation. Set "sysctl vfs.usermount=1" if you want to be able
-to mount fuse devices as an ordinary user.
diff --git a/sysutils/fusefs-kmod/pkg-plist b/sysutils/fusefs-kmod/pkg-plist
index ddbf0885253..c8a8b6d211d 100644
--- a/sysutils/fusefs-kmod/pkg-plist
+++ b/sysutils/fusefs-kmod/pkg-plist
@@ -21,3 +21,5 @@ sbin/mount_fusefs
%%PORTDOCS%%@dirrm %%DOCSDIR%%/kmod/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/kmod
@dirrmtry %%DOCSDIR%%
+@cwd /usr
+sbin/mount_fusefs
?h=gstreamer0.10-removal&id=eb40c1517641178bec0ecf66280678914e2c3193'>Change MASTER_SITES to the new locations.sada1998-11-232-3/+4 * Blindly update to Fortify-1.3.0 as Fortify-1.2.6 isn't fetchable anymore.obrien1998-11-192-6/+3 * Upgrade Fortify (128-bit encryption)markm1998-08-242-6/+6 * Add NO_LATEST_LINK -- these are not the latest versions, and we shouldn'tasami1998-04-041-1/+2 * Fix for the case where USA_RESIDENT is not defined.markm1998-03-161-4/+5 * Using Fortify and setting USE_128BIT, this port can now do 128 bitmarkm1998-03-152-12/+23 * Remove RESTRICTED tag.vanilla1998-01-261-2/+2 * tarball checksum changed.jkh1997-11-231-1/+1 * Make these coment lines a little more useful. (Remove redundancy withasami1997-11-151-1/+1 * Update to version 3.04jkh1997-11-143-9/+9 * Add checksum fo the gold version.max1997-10-161-0/+1 * updatewosch1997-10-041-1/+1 * Upgrade to 3.03ache1997-09-242-9/+8 * Install movemail with x-bitache1997-02-251-2/+2 * No `.' is needed at the end of the reason string for NO_CDROM, NO_PACKAGE,max1996-12-081-3/+3 * Add ${DIST_SUBDIR} in front of filenames in files/md5. Corresponds toasami1996-11-302-2/+2 * Compress a bunch of manpages. Remove unnecessary @ directives fromasami1996-11-182-1/+4 * Use MAN? macros. CATEGORIES+= -> CATEGORIES.asami1996-11-181-2/+9 * Build Netscape Gold, if GOLD variable is definedache1996-11-121-1/+7 * Upgrade to 3.01, netscape301 will be removedache1996-11-075-10/+10 * Upgrade to 3.0 releaseache1996-08-193-7/+7 * Upgrade to 3.0b7ache1996-08-132-6/+6 * Update to the latest BETA.jkh1996-08-034-8/+8 * Slightly change path.asami1996-07-191-2/+2 * Seems like 3.0b5 has been removed from the ftp sites and replaced byasami1996-07-052-5/+5 * Upgrade to 3.0b5gpalmer1996-07-022-6/+6 * Change NO_PACKAGE to RESTRICTED, this is commercial software and we can'tasami1996-06-091-3/+2 * Add "application/pdf; xpdf %s 2>/dev/null".asami1996-05-301-0/+3 * Upgrade to 3.0b4ache1996-05-232-6/+6 * Explicitly initialize CLASSPATH to avoid confusion.jkh1996-05-161-0/+1 * Upgrade to b3ache1996-04-252-6/+6 * Add a note about fixing the Java applet display problem that some userssmpatel1996-04-041-0/+6 * Fix path on master site, the tarfile was two levels lower.asami1996-03-301-2/+2