aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/archmage/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-02-23 04:06:53 +0800
committersem <sem@FreeBSD.org>2005-02-23 04:06:53 +0800
commit7247dfa17b6d11612a0210e443a93f27b49f1c7c (patch)
treeaf56e32ddb0a3812c3afc7c43b41d641d838fd95 /textproc/archmage/Makefile
parentd15aada75591d7e988c848a1b61e277e42029c9b (diff)
downloadfreebsd-ports-graphics-7247dfa17b6d11612a0210e443a93f27b49f1c7c.tar.gz
freebsd-ports-graphics-7247dfa17b6d11612a0210e443a93f27b49f1c7c.tar.zst
freebsd-ports-graphics-7247dfa17b6d11612a0210e443a93f27b49f1c7c.zip
New port: ArCHMage is extensible reader/decompiler of files in CHM format.
PR: ports/77930 Submitted by: Vsevolod Stakhov <vsevolod(at)highsecure.ru>
Diffstat (limited to 'textproc/archmage/Makefile')
-rw-r--r--textproc/archmage/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/archmage/Makefile b/textproc/archmage/Makefile
new file mode 100644
index 00000000000..cfbb3832176
--- /dev/null
+++ b/textproc/archmage/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: archmage
+# Date created: 22 February 2005
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= archmage
+PORTVERSION= 0.0.6
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= archmage
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Extensible reader/decompiler of files in CHM format
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/chm/_chmlib.so:${PORTSDIR}/textproc/pychm
+
+NO_BUILD= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_INSTALLARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ install -c -O1 --prefix=${PREFIX}
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/share,${PREFIX}/share," ${WRKSRC}/arch.conf
+ @${REINPLACE_CMD} -e "s,/etc/arch\.conf,${PREFIX}/etc/arch\.conf," ${WRKSRC}/CHM.py
+
+.include <bsd.port.mk>